E0 Temp ?

all seems to be working except the heater...

I have a 24v heater e0 when I turn on the heater say to 200 the led go's on, on the ramps and I set the temp is set to 200 on the lcd screen and also the temp shows it's raising up to 200 and that it reached 200 and is holding.

The problem is it doesn't seem to get hot it may go up a few C%'s  but not much I have a temp sensor I point at the hot end and its still only showing around 30%c ...

I tested the voltage to the heater from the ramps and its putting out 23.5 should be plenty to heat up...

I don't understand why, the temp resistor reading is sending back a rise in temp up to the 200 on the lcd screen when the heater doesn't seem to be heating up much I can touch the  wire about an inch from the hot end and not get burned.

any suggestions 

Thanks gary


  • So output gets power and sensor tells you it reached 200°C and you can still touch it. You could have selected the wrong sensor type or you have 2 heaters and it is heating the other one.

    Try only testing the sensor. When cold put it in your hands to get it to 33°C you should see that in lcd. If it shows 200°C the sensor type or measurement circuit is wrong. If it doe snot move at all you have another selected that gets the power as well.
  • what I tried is I turned on the system it was reading 25%c I took my wife's hair dryer pointed at the sensor it went up to around 68%c and seemed to be holding there.. I have a bed heater and sensor also but don't thing its reading the wrong one and I am pretty sure I have the right sensor chosen in the config. I found another 24v heater in my pile of junk so I will wire that one up and see if it heats correct..
  • Good test. Sounds sensible for the sensor. But why can it report 200°C when it is 30°C. That part is weird.
  • can't figure that part out I point my digital thermometer at the hot end and its highest reading was around 55%c

    I tested the digital thermometer at the oven and it went right up to 260 so I assume it wasn't that

    if I took a piece of the pla and touched the hot end tip it would start to melt but not like it should so I assume it is getting hotter that 30 to 50 just don't know why the digital thermometer is not picking up anything higher that the 50's... and that's not the tip it reads the slightly higher temps in middle of the hot end and I don't think I should be able to touch it an inch from were the wires go into the tip.. 


  • guess you are trying to measure hotend with IR thermometer.
    This cannot work because of emissivity of metal surfaces. refer :

  • I thought that might be the problem...

    So what do you do to check if the temp match's what the sensor is reading ?.

    Thanks gary 

  • just can tell you what i did at the beginning..
    i took calibrated thermocouple and removed the nozzle to measure inside the heater block.
    absolute nonsens.    why?
    the filament temperature will never be the same, it usually is not long enough in the heater to reach heaters temperature( depending on printing speed, layer height, nozzle size etc...)
    it just heats up, you never know exact temperature.
    The temperature reading is just something "over the thumb" so at the end you have to find the setting for
    your filament on your printer.

  • new problem dried pid audotune set at s200 the hotend reached around 80 stays there for a min or so then error's out

    when I try to heat it normal it reaches 60 and errors out and takes a long time to reach the 60..

    Any suggestions tried two different thermos's

    Thanks gary 

  • 80°C is not much, sounds more like the limit for a heated bed. Did output power show 100%? If not you can increase pid drive max, which is often limited to 140 from default values. If you increase to maximum 255 then you see the real max. heat, also from 80 to 200 is a long way. So it could also be having a 24V heater on 12V which does not really heat good. Or it is in deed the bed you measure. 
  • I got the hot end heating up ok now.. heated to 180 and held ok..

    Now I can't get past 45 on the hotbed so guess I will keep plugging away at it.

    Thanks gary

  • Can't seem to get things going correct..

    I calibrated the print bed z center and a b c corners are all good

    When i print its way off the printer moves to what it thinks is at 5.0 above bed after the heaters have heated but it is only half way down to bed..

    when print starts hot end heater all ways errors and i get def and shuts off the hot bed stays ok

    then it starts printing but at half way down to bed so just printing up in the air.

    i used slic3 and repetier  host...

    any suggestions as to why it calibrates ok i can do a z0 and be to the paper on the  bed

    but when i do a print it thinks the z is half the length.

    Thanks gary 

  • First check you have no z min hardware endstop.
    Then check G28 G0 Z0 is at the bottom.
    If both is the case printer configuration is correct and I would start checking the start gcode if it has for example a G92 Zx from previous configurations that can cause offsets and whcih Z coordinates are used. There should be a G0 Z0.2 or something like that before the first print move in gcode.

    Check also isolation of hot end sensor. if it defs on moves it might be a broken sensor cable that sometime has contact or 2 free parts that get into contact. Both are typical pattern for heater works when still and not while moving around.
  • I have just noticed when i send a g28 to home when i looked at the lcd

    it shows that z is 901 not sure why i have the z length set at 313.00 one it hits the home z changes to 313

    and if i do a g1 z0 it stops paper thin from the bed..

    and getting other strange results when sending a g code file seems when its gets the g28 to home it go's to home in segments moves say 25.0 stops moves again keeps doing it till it reaches home..

    and i do have zmin enabled i have the probe setup zmin pin

    the more i mess with this I'm starting to think i have a bad ramps board..

    I had to use E1 for extruder couldn't get E0 to work with motor..

    Thanks gary

  • The big coordinates should not appear on 1.0 version, so which are you using? They are no error though, for homing we go a big distance up which you see and stop when triggering endstops.

    What kind of printer do you have? Cartesian or delta? Deltas reduce moves into submoves and depending on planner state it could not optimize full move so it slows down mid move. Does not happen in full print when buffers are full as it then has enough time for planning (except you configured it wrong to use more then 100% cpu time, then anything is possible).
  • delta  newest version of  Repetier
  • Deltas work much faster on due based boards like RADDS. Check that z steps pre mm * max speed < 15000-20000 or your cpu can not handle it. Also depends if you have a display. Especially graphic displays also eat much cpu time.

    But even on due you will see speed changes mid move when buffers are not full, especially first moves and homing. So that would be ok.
Sign In or Register to comment.