Endstop distance after homing

Hi guys I have a little problem here, After hit endstop min at X axis head is moving back arround 20mm. What can be wrong ?My Endstop distance after homing is set to 0 


  • Is this after the second end stop test? These

    // When you have several endstops in one circuit you need to disable it after homing by moving a

    // small amount back. This is also the case with H-belt systems.

    #define ENDSTOP_X_BACK_ON_HOME 1

    #define ENDSTOP_Y_BACK_ON_HOME 1

    #define ENDSTOP_Z_BACK_ON_HOME 0

    set the planned distance from endstop after homing so you can have them untriggered on all moves.

  • #define ENDSTOP_X_BACK_ON_HOME   is set to 0 any way axis still is doing this funny move 
  • So how often does it test endstop in your case? Sounds like once go back and then it does not retest because endstop is already triggered. Test M119 after homing x and see if it is triggered also being 20mm aways.
  • Homing procedure is normal this what I got here looks like ENDSTOP_X_BACK_ON_HOME is set, but is not. So X endstop is trigered X axis is moving back 5 again touching endstop one more time then, move 20 back.
  • Tomu, pls post your config.h and i will look it over.

  • Sorry I dod not have a time for that, will start again tomorrow then will sent you config 
  • Hi all,

    same problem here with my d-bot. 
    any solutions yet ? 

  • It is ok if you have a dual extruder. That way you can select second extruder at X0 without hitting the endstop. Homing with T1 active would then have no extra space.
  • i have indeed a dual extruder, a chimera from E3D.
    and i used the settings from E3D, ext0 at -18,0 and ext1 at 0,0 

    than when i home x the carriage hit the end stop and moves away from the endstop to its starting position
    but the carriage needs to stay against the endstop for homing Z-axis 

    i played with the extruder offsets and the park position after homing in the fw but it keeps moving away from the endstop. 

  • Yes it will in deed always move 18mm away if extruder 0 is selected. With E1 selected it will as you need it. Or if you have the x endstop at x max you would have no gap for E0 selected.

    You can test if you can go to X=-18 then you could defined x home position to -18 with the risk of a crash if you home with second enabled. Requires homing order with preheat option which you can set to 0, but it will also show the option to set z homing position. Only thing is I'm sure normally the allowed coordinate test will prevent going to negative positions.

  •  thanks, i have tested it with ext2, and yes it stays where i want it  :)

    is it possible to change the original homing script, so it always select ext2 while homing ? 

  • You could rewrite the G28 command in commands.cpp to store old extrude rid, select 1 do stuff and select back old extruder.
Sign In or Register to comment.