Ubuntu and can't upload Firmware

edited December 2017 in Repetier-Firmware
Hi, Ubuntu 16.04 and I am trying to use Repetier firmware (latest download) on an Anycubic Linear Plus.

I have no problems connecting to the printer at 115200 BAUD with Arduino and uploading other firmware, Marlin 1.1.4 and 1.1.6 and the Anycubic version of Marlin 1.1.0RC so I know the printer talks to the laptop OK.

I have changed the BAUD in the configuration.h to 115200 and on upload, I am getting a clean-compile, a warning about the risks of 85% Dynamic Memory usage and then

avrdude: stk500v2_ReceiveMessage(): timeout

that is repeated about 15-seconds.

I tried using the configuration.h default BAUD rate of 250000 and it did the same, but with Ubuntu I think it needs an even multiple, so tried 230400 but that does not work either.

How can I get this to upload without having to borrow a windows PC from a neighbor, which I believe can use 250000 BAUD?


  • Ignore this, I borrowed the neighbor's win8.1 laptop. But still have problems, see latest two posts.
Sign In or Register to comment.