Cannot get extruder temperature to set correctly

When I start Repetier Host the extruder temperature is displayed as 200 on the Manual tab.  But when I start a print, the extruder temperature suddenly becomes 210.

I have checked the printer configuration and all of the Cura settings, and I cannot find the number 210 anywhere.  I also checked the startup GCodes.  In the GCode, there is a variable called "TEMP0": I do not know how/where the value gets set, nor what the value is.

Can anyone suggest another place to look for the 210?

Comments

  • First check the generated gcode for M104/M140 commands. Then you know it was added by the slicer. TEMP0 gets replaced by the temperature in the filament description in CureEngine configuration and that is most likely the source of the temperature.
  • As I said, originally, the CuraEngine Filament Print Temperature is 200, and yet the extruder temperature is set to 210 when a print starts.  You are correct that the temperature shown in the GCode is 210.  But I never specified that temperature anywhere.  I can work around this by editing the GCode for Print Start to have 200 in there explicitly, but that would defeat the purpose of the TEMP0 variable.
  • Sounds like it is not using the filament settings you think it should. Make sure you have set it in the right side, not in the left general configuration.
  • have you checked the start code in cura settings,
  • Thank you.

    Not sure what the "right side" is.  I note that, as I said before, the Filament, Print Temperature is 200.  I don't see "General" anywhere.  I open the Slice tab and click on the Configuration button and then go to the Filament tab to set the Print Temperature.  Is there some other way to do this?

    Not sure what "checked" means.  Enabled?  Verified?  The Cura GCode is clearly being emitted, and by implication the value for TEMP0 is 210 when I have specified it as 200.

    I'm sure I am confusing something; I'm not sure exactly what.
  • Left side configures temps etc for different config names. That doe snot mean they get used. On the right side where you slice you have so select the filament where you have set 200°C as temperature or it will use a different one with that temperature.
  • There is only one extruder profile defined, and it is correctly selected.  It specifies 200 C while the emitted GCode shows 210 C.
  • are you using cura engine (integrated in Repetier Host) or do you use separate Cura ?
  • I am using the CuraEngine that is part of Repetier Host.
  • So.  No suggestions?
  • edited November 2017
    You are correct about the 200 when it shows initially. 
    If you are using the default profile (under CuraEngine) and the filament temp is set to 200 it SHOULD compile at 200.
    The start g-code script is under Slicer - CuraEngine - Configuration - Print - G Codes.
    There is also one under Config - Printer Settings - Script - Start Code on the upper Tab above the viewing window.
    I don't use the Original Start g-code script, I modified it for my own situation. I don't use the TEMP0 / TEMP1 variables.
  • Are you using version 2.05? Some older versions had problems with selecting the profile.
  • Here is the workaround for this bug in Cura temperature setting in Repetier.
    1- In the cura slicer configuration setting, on the Print tab, do a "save as" of the default setting into another name "MyDefaultSettings"
    2- In the cura slicer configuration setting, on the filament tab, do a "save as" of your filament setting "ABS"
    3 - Setting DONE!
    4- In the tab Slicer (just before you print), select the print configuration "MyDefaultSettings" and the Filament settings "ABS"
    5- it finally generate the right temperature into the G-CODE.

    Repetier version : V2.1.3

    It looks like if you still take the printer default setting.. Repetier can't take any different filament setting than default.. even if you selected it!
Sign In or Register to comment.