I can't get Z_PROBE_START_SCRIPT "M340 P0 S2375" to work in firmware. It won't lower the probe at auto bed level. Manual lowering the probe in console works fine. After the bedleveling Z_PROBE_FINISHED_SCRIPT "M340 P0 S1425" works fine too. Using the latest 1.0.0dev firmware.


  • Ok have checked it. Found that there is in deed one condition when start script is not called and that is


    If you need a servo to position z probe that should not be the case or you have configured it wrong. Anyhow, update is online. If it still happens please test also with

    "M117 Activate Probe\nG4 S5"

    which shows a message at least for a short while in display. And try "G30 P3" to see if that runs the script. Here I know for sure it runs, also it run as well on G32 for me when testing now.

  • oh man *facepalm* that's why i have all the trouble with probing. I spend hours to get my z-probing right after i changed some things at my printer. I overlooked it in the settings and have never thought about that.
    I get back to you with the results
  • Well checked it, EXTRUDER-IS-Z-PROBE IS set to 0. It looks like my problem is in the points it want to probe.

    When i start bed leveling, Z lowers to x-mm to the bed, here it is supposed to lower the probe-arm. But before it lowers the arm in console i get this warning:

    fatal:Could not activate z-probe offset due to coordinate constraints - result is inaccurate! Printer stopped and heaters disabled due to this error. Fix error and restart with M999.

    And goes up a certain amount. After that it continous probing (without restart or M999) without lowering the probe. Strange thing is that it happens when i try to probe X20/Y20. When i set the probing point to X30/Y30 it works like its supposed to.

    What could be going wrong here?
  • Ok, that would be correct except that it should stop probing completely and not just issue a warning, so error check is not correct here.

    The problem comes, if firmware sees that activating probe at current position would move outside allowed print area. So z probe offset to active extruder were > 20mm and < 30mm. Note that extruders can also have an offset so move is difference of both offsets!
  • Ok, sometimes its better to stop and do some other things. Driving home today from work with this answer in my mind i suddenly saw the light :) I forgot i made some changes to my Y axis, Y home is 0 now, before it was -7. Probe offset Y is 21mm...
    Problem solved, tnx.
Sign In or Register to comment.