Heated bed issues with Repetier Firmware and Mendel

Hello!!! After conducting PID test for heated bed(Repetier-Firmware) MatterControl gave me an error (#91 if I remember right) and my bed stopped working. I checked voltage on terminal and got 0. After jumping around with a drum I installed Mendel-Firmware and bed was operable with (12 V) on terminal. I have tried to reinstall Repetier-firmware with different heated bed settings but still cannot get current on HB terminal.

If you encountered similar problem please share your thoughts. Thank you. 


  • You shoudl check th elog. Repetier writes to log why it disabled bed. Normally some decoupled message.
  • I have found the answer by comparing pins from Marlin and Repetier-Firmware. The latter was set on pin 10 for HB and Marlin has 12. Thank you.
  • For which board? RAMPS has bed on pin 10 but others of course can differ from that. So if we have an error in our board description I'd like to know so I can fix it.
  • That was GreeenTech  Melzi 2.0. The funny thing is, this error came up only when I tried to do auto PID test for my bed. When I installed Repetier-Firmware first time everything was working fine.  And now every time I try to do PID for heated bed the HB terminal just shuts off and have to reinstall Firmware and change pins(but that is minor work around).
  • Ok have changed it to 12 for next update as it seems correct. No idea where the 10 came from. Even saw a comment that it should be 12 for break out board, whatever that meant. Probably a very old melzi version was differently.

    Why do you need to change pins on a new firmware upload? Also that should not change anything. A normal reset would also restart firmware. Could it be a fuse resetting so output stops? I know that RAMPS bed fuse is quite tight designed for some beds. Not sure what melzi uses here.
Sign In or Register to comment.