Filament Tracking with Due and RADDS

Hello everyone,

I installed the Sparklab Filament Tracking System and got it to work after some issues. Now I'm left with two questions/problems:

First: is there a way to turn off the tracking during "non-print" extrusion (Filament change, "manual"  extrusion via Repetier server)? The problem is that my tracking system is not triggered  during these actions (because of the mechanic setup of my printer), so I always get an "extruder jammed" message on the 4x20 LCD Display of my Radds. I don't want to connect this display on my final build and I get the error message only on the RADDS-display, not on the console output. So on Repetier Server it looks like everything is fine.


my second problem: If my extruder jams or i'm out of filament during a print, my printer uses "JAM_ACTION 2" to pause the print and let me change the filament/unjam the extruder as expected.
After I fixed the problem and unpaused/continued the print via Repetier Server, everything seems fine since my printer is continuing its print and I don't see any error messages on the console output. But as I described before: when I connect the LCD Panel, i can see that the extruder is still marked as "jammed".
This would not really be a problem, but the jam detection is not working anymore. So if, during a very long print, my extruder jams up more than once, the tracking system is not working for the second jam.

Is this a bug or do I have to set something in the pause handling of Repetier Server?

Thanks for reading and helping
Jagi

Comments

  • See these jam related commands:

    - M513 - Clear all jam marker.
    - M602 S<1/0> P<1/0>- Debug jam control (S) Disable jam control (P). If enabled it will log signal changes and will not trigger jam errors!
    - M603 - Simulate a jam
    - M604 X<slowdownSteps> Y<errorSteps> Z<slowdownTo> T<extruderId> - Set jam detection values on a per extruder basis. If not set it uses defaults from Configuration.h

    So in continue use M513 to delete jam marker and set feedrate to 100% using M220 S100 if you have a slowdown enabled.
    You could use M602 to disable it for extrusion, maybe making it a named command for frequent use. Currently there is no way to do this automatically.
  • edited October 25
    Thank you very much for your answer, it perfectly solved my problem.

    Are the new values set by M604 permanent or are they lost after printing or rebooting?
  • They are lost after reset, but as advantage you can set them per extruder and not glabally for all. Usefull if one filament is weak like flexfilament.
  • Perfect, thanks!
Sign In or Register to comment.