Version 1.0.0 Release Coming Soon?

Any news on when release 1.0.0 will move from Dev to Production?

Comments

  • Not really, but will not take too long. It is already usable in production.
  • Is there an "open bugs" list on 1.0.0 we can see to gauge how ready it is?
  • No such list, but less bugs then 0.92.9. Only thing I know is that deadtime control is not so good any more since we changed temperature handling for better PID performance due to lost time precision.

    Only thing I want to add is chamber temperature. Guess then I will call it 1.0.
  • Hi,

    any chance the ultratronics pro v1.0 ethernet port is gonna be added in the dev version of the config tool?

  • How does that ethernet work? Is it a chip that converts ethernet to serial data? Then you could simply select the right serial port/baudrate. But we do not have that board, so we can not test etc. But if someone provides required code we will of course integrate it.
  • will do some research on that the ethernet and i will keep you informed.
    I also have something very strange going on with the axis movements.
    I set all steppers to 160steps/mm and homing (xyz towers on my delta printer) homes perfectly, z-axis movement could'nt be better and is accurate (i use 1/32 stepper drivers).
    But moving X or Y axis seperate, the movement is 3mm instead of 1mm, also on the graphical lcd my movement is only 1/3rd of what is really happening. Anybody an idea of what went wrong?

    I also tried to edit the config file and lowered and increased the steps/mm on those axis but no change of behaviour, what i do find interesting is the fact that in config.h there are 3 individual lines, 1 line per axis to let the firmware know how to act.
    But when you open in repetier host the firmware eeprom configuration window there is only 1 line (i presume it is the Z-axis line because it is the Z-axis value). A little help would be greatly appreciated :-)  

  • edited October 27
    Hi again,
    At reprapworld i was able to find this 
    UltratronicsEthernet

    This is a library for Arduino adding support for ENC424J600 chip

    https://reprapworld.com/products/electronics/ultratronics/ultratronics_pro_v1_0/#productdetail

    there are also links to the library's but i'm new to all of this and i don't know how to implement the modules or combining them to get it all work with the firmware download that i got using the configuration tool (1.9.2 dev).

    It would be nice (for a next upgrade) to implement a choice in the config tool to use the ethernet port (just a thought).

    As for the fact that you don't have a ultratronics board to test on? would it be helpfull that i donate you one in the near future? It would have to wait untill december because i just bought my second DIY delta.


    Have a nice weekend Repetier :-)

    Johan



  • Deltas have in deed only 1 resolution since all are identical or the math would not work.

    Z is easiest to calibrate since 1 step is 1 step for all motors - no nonlinearities. So calibrate first z movement so 100mm are 100mm in real, then check again xy. If they are still off the reason should be a completely wrong diagonal rod length/horizontal radius. Especially if you use the escher algorithm to calibrate you need to make sure to use the version with fixed diagonal rod length. This var can be measured quite good by hand and changing it changes printed xy size. If you allow it to be optimized for z height it will adjust it to get a plain bed neglecting sizes as this can not be measured with z probe.

    Regarding board I just wrote to ultratronics a mail as they always wanted to send me one when it is in production. Already worked with them to add the initial support in repetier which you are using now, so lets hope I get one.
  • all the diagonal rods were adjusted to the same length, 198.5mm horizontal radius is 164 and printable radius 105, all the offsets are measured and on the mega2560 and rumba board with marlin firmware everything worked fine. i even accomplished a bed levelling of 0.02mm with manual calibration and a micrometer clock installed instead of a print head. So you can see how i'm about getting a slight head pain out of this, lol. I really don't know what i am doing wrong. I also don't use the automatic bed levelling because it just failed to much in the past, i already spend a reasonable amount of time in mechanical perfecting the bed levelling to get it mechanically levelled.

    At least you are showing interest in the whole matter, for the marlin fw i had to figure out everything on my own, i needed over a week just to figure out how to compile the damn thing, lol

    Thanks for quick responses  

  • Since there are only 2 parameter making the xy move wrong I need to ask again. z steps per mm working exactly? Can be easily computed from belt type, steps per motor rotation and tooth of pulley.

    Also diagonal rod. Same length is great but did you measure from rotation center to rotation center or something different?

    Also check in eeprom if angles are 90/210/330 and steps per mm are set in eeprom which is what gets used and not the configuration.h values.

    Please also measure xy moves for 50 or 100 or 150mm. I think the error in center will be the biggest and get less to the sides.
  • All the measurements are from centerpoint to centerpoint.

    As i noticed, the Z steps per mm are the only ones showing when connecting through repetier protocol in repetier host. The repetier host i am using is the latest one. and i have the repetier-server pro 0.86.2 running too.


    I'll continue the measurements during next week and i will keep you informed.

    Great that you contacted the ultratronics guys, i hope you can get a board from them, would be a huge advantage when you can actually test it yourself.


      

  • Deltas use steps per mm z for all axis.

    Yes I hope they send one.
  • Solved the radius issue on my ultratronics-repetier build, when i set the slider and carriage parameters with - values like -20 then i have full and accurate movement on all axes.

    Next problem, the bed center on the arm movents results in a higher position then moving away from center so i get bed touching around 50mm moving x or y but in the middle it is at + 0.5mm.

    Where or which parameters need to be adjusted?

    Thanks again for all the help

    Printing a 20x20x20 testcube right now to see how much the movements are off


  • Not sure which parameters you changed but sounds like for horizontal radius calculation. In eeprom they do not even appear if it is that as it is just subtracted from a variable if you use the classic way of changing configuration manually, which we normally do not do (use config tool normally).

    The ratio diagonl length/horizontal radius causes it to dig/dive towards the center so either change diagonal or horizontal length to adjust here.
  • aaah ok that way, thanks, this helps me a lot.

    Thanks for pointing me in the right direction :-)


  • i suppose the variable you are talking about is calculated somewhere in the driver.h file?  but i try first the way of changing diagonal and hor radius.

    I think it was in Marlin that they actually calculated the variable in config.h

    with this line

    // Horizontal distance bridged by diagonal push rods when effector is centered.
    #define DELTA_RADIUS (DELTA_SMOOTH_ROD_OFFSET-DELTA_EFFECTOR_OFFSET-DELTA_CARRIAGE_OFFSET+1)

    At the end of the line "+1" is adjustable to compensate the dig/dive error

    Yes i worked with Marlin before but for some reason i can't compile it to work on the Ultratronics board. That is why i switched to Repetier in the first place.


  • We have the same in configuration.h but only the result gets set and in config tool you would also only enter the result.
  • Thanks again Repetier, finally got the axes levelled out as the should be.

    Slight adjustment is still needed but now it got it from 4mm to 0.2mm on the entire surface, so i guess for just manual levelling it is coming all together a bit at a time, instead of working before the decimal point i can start again after it.

    Thanks again for all your time and patience.  

Sign In or Register to comment.