baud rates cant change

been having some issue with the Ramps 1.4 and repetier 0.92 firmware
have an issue with the checksum error and reset (while printing) this causes a wart on the printed pieces many of them read that this may be caused by the USB cable replaced with a shielded better USB cable seemed to help also tighten belts then had to readjust the motor current seems to be printing OK.

Then it starts with an error message while trying to connect invalid checksums etc.. but is not while printing, no file loaded?
read someplace that this maybe an issue with too fast a baud rate was 250000 been working good until recent issues above.

Updated the Config h and rebooted, change the baud rate to 128000 in host  wont connect.
 went into the display and it was still 250000
changed it manually to 128000 and stored eeprom then tried with host to 128000

Wont connect and it just keeps showing error> invalid checksum until it reboots windows 10 ? very odd behavior
so i reset to 250000 connects and works

reloaded config h to ramps
display ramps config chang d maually
Repertier host changed

was going to try reloading repetier host, but had to go to work.
plan to order and install radds eventually.

why wont it let me lower the baud rate only work at 250000?


  • First if you change better set it to 115200 baud. Uploading firmware does not change baud rate because it is stored in eeprom and you did not update the eeprom.

    If you have a lcd display just go to config, change baudrate, go back and store eeprom to make it effective. Then it is changed for next connection. 

    If not, open in eeprom editor, change there and save. But be sure to select a valid baud rate or connection gets impossible.

    Last solution is uploading firmware with modified EEPROM_MODE which makes eeprom values to be copied from configuration.h.
  • modified EEProm? is that the config file in Host wont go active because was not making a valid connection. will try again as maybe it was the order in which i tried to do it :>)
  • edited September 2017
    got it working @115200 now changed in the display and stored and changed in Host to 115200 working now to test and see if i still get invalid reset checksum  Thanks
  • after 130 of 505 layers no errors or invalids and no warts ( bubbles in the print layers) thanks again,
    much appreciate the help

Sign In or Register to comment.