mega 2650 error: temp. raised to slow rise = .043 after 13079 ms

I have order new correct watt heaters, tried different ext. Connection on board, and also voltage tested at all connections from power supply. I cleared the eeprom and reloaded factory firmware as well. Any thoughts why its not heating fast enough? I am running 3950 100k thermistor an 40w ceramic heater on v6 hotend clone. With no fan it will creep to temp after about 5-10 minutes, with full fan it times out everytime.


  • sounds like operating 24V heater at 12V Supply...
  • They are 12v heaters, i bought them new to verify. 3.5 ohms when i tested.
  • In addition i swapped known working thermistors and tested the heater via the other connections on the mega(heated bed and 2nd extruder input)
  • did you do a PIDtune? 
  • I have, maybe not in the correct fashion? Would that make it stall at 140c with full fan on the hotend? I had everything working, then i was tweaking eeprom retract settings and it hasnt been heating right since
  • what´s your Max PID setting?

    should be:

     #define EXT0_PID_MAX 255

  • For debugging always use a temperature monitor on server or host. There you see output power. If it needs rising a good part it should increase power to 100%, if not config has limited PWM like RAyWB said, if it is 100% you have not enough power for more temperature.
  • edited September 2017
    nvm, miss read problem
  • Pwm is set to 255. It basically hits a wall once it is over 140c. What do you recommend for hz on a 40w 12v heater? I am stumped, as i have switched the boards out and tried a marlin firmware install but the issue still persisted. I went back to the previously runningg repetier firmware and board as nothing changed.
  • did you measure hotend temperature by external Thermometer or

    did you try to push Filament through the Extruder by Hand? as MartinH wrote it also could be reading problem

  • I cant measure much over40c. It is not completely accurate. This may have somthing to do with it. Also the firmware i downloaded did not have a thermistor table in it, is this required in repetier or is it buried in one of the arduino sketchs?
  • Also check

    default is quite limited and that is max. when control takes over. But a temperature curve as I told would you show directly what the error is.

    Firmware contains some typically used thermistor curves, so if you selected the right type that is ok.
  • I believe i selected the correct type, i will also post a screenshot of the curve when i get home this evening.
  • what controller board are you using ?
  • Mega 2650 with ramps. I believe it is a knockoff, as it is from he3d for their delta k200
  • Mega 2650 with ramps. I believe it is a knockoff, as it is from he3d for their delta k200
  • attached is the temperature graph
  • 17:44:52.528: Error:One heater seems decoupled from thermistor - disabling all for safety!
    17:44:52.528: Error:Temp. raised to slow. Rise = -0.25 after 31049 ms
    17:44:52.544: Disabling all heaters due to detected sensor defect.
    17:44:52.544: DebugLevel:14

Sign In or Register to comment.