thermocouple setup

i use the dev branch and have not had any major issues with it

only the G33 which i will retest this week as soon new stepper drivers from watterott comes in. so far i'm on a 20/7-2017 relase

but i would also like to change out the bed thermistor for a thermocouple as i have to disassemble the who bed assembly to change out, and i have an idea that a thermocouple is a bit more though.

in the online config i can select MAX31855,  but where do i select the CS pin ? is it the Temperature sensor pin


  • Yes, HEATED_BED_SENSOR_PIN  becomes the cs pin.

    G33 has changed a bit with yesterdays release. Hope to have fixed some bugs with offsets.
  • you will know today... 

    right now i'm soldering up some tmc2100 drivers and once i have them in place i will do a G33

  • edited September 2017
    i ran a G33 and got this:

    it seems like the old error is still there, if it helps config is attached 
  • edited September 2017
  • Are you using the dev version?
  • yes, and i downloaded it today

    i still have the old dev version that works so i can switch back and forth
  • The new version should home if necessary and go to a position where enabling is possible. I need more information to debug this since it is working fine on my delta. What happens when you start at a valid position like center of bed? Are your configured edges inside reachable area? What exactly happens and at what stage do you get the message? Log?
  • first my manchine is a cartesian one

    the same thing happens no matter where i start

    what happens is that it homes and then it try to go past my X endstop

    i could get a log if i knew where to get it

    maybe  a short video would be better if i can get my phone to do it in decent quality
  • edited September 2017
    and my configured edges must be valid since it worked on the dev version published 20/7-2017

    i see that my config did not get attached 6 posts up

    here it is:

    that should at least tell if my config is valid or not
  • #define Z_PROBE_X_OFFSET 19
    #define Z_PROBE_X1 18
    #define X_MIN_POS -3
    #define DISTORTION_XMIN 18
    #define DISTORTION_YMIN 23

    Just for reference the important config options for the problem.
    After homing you are at x = -3 and for the leftmost position it will be at -1 so 2 mm a part from x endstop. But at xhome positions it can not activate z-probe.

    For initalization it calls void Printer::prepareForProbing() which is a new function to prepare to a valid state and I guess there the error starts.

    At beginning it homes, which works.

    Next is going to safe position, which is not needed on deltas, so I could not test that part (have only a delta with z probe).

    Computation of target x position
        if(ZPOffsetX > 0 && targetX - ZPOffsetX < Printer::xMin) {
            targetX = Printer::xMin - ZPOffsetX;
    that is -3 -19 = -22, so guess that is what you experience.
    Correct would be
            targetX = Printer::xMin + ZPOffsetX;
    like I wrote in the remaining 3 cases.
    Have updated the firmware and should now work better.

    Thanks for the bug notice.
  • just to be clear 

    at home nozzle is at -3 on X

    the probe is monted on the other side of the nozzle so it will be at X15

    why i say this is that i have become unsure if my config is wrong
  • No, as I said my computation for x was wrong. Config looks good. Just try new version I just uploaded.
  • had a chance to test it today

    works fine now on my mendel90 :-D
  • Perhaps working out which Thermocouple is right for you may assist? Check out

    Or feel free to call one of our offices (see our contact page)

    Good luck :)

Sign In or Register to comment.