After lightning storm and power fluctuations: "A is hitting bed error" - But it is not


So, I got my printer more or less working - Turns out the fine tuning of the various lengths are very important...

It is a delta printer, much like the mini kossel one (K800 mine is called). It is running on Arduino Mega 2560 and Ramps 1.4

So I made the not so wise choice of just wanting to check one last thing while in the middle of a thunder storm and power fluctuations on the power grid. 

There was no smoke or the slightest indication of anything - And everything else electronic in the house is fine. But my steppers are now frozen. When running I get the error that A has hit the bed floor. I get that error twice and then in Reptier host the Z value goes to max val.

My question is: What exactly should can I understand from that error? Is there some intelligence to it so I can assume an error in the A circuit or is it just a standard output when drawing too much power?

In case it should be of interest - Under all the following conditions, the error is the same:

1) Changing cables around
2) Removing the stepper cables entirely
3) Removing the stepper drive(s) circuit (the one(s) that can be taken out)
4) Removing everything entirely so only the board on top of the Arduino

The following is also true:

- The heating circuit for the extruder still works (it heats) and so does the thermistor.
- No stepper works, not the extruder, no nothing. Running the extruder does NOT give the "A hit floor" error, just nothing happens.
- All motors are "on"  when I ask them to move and I can see commands being sent by measuring with my oscilloscope on the output pins - But no movements. Thus you cannot move them by hand after you ask them to move and the motor is doing the "humming" thing.
- I have tried a different power supply but my alternative is only 1.5A - Not sure if that is enough to drive anything. It still gives same error. 
- The output voltage is correct on the power supply and measuring with my DMM on various points gives what I expect for voltages

Ok - I think I have fried the microchip on the Arduino. I am not very skilled with electronics and don't feel confortable starting to de-solder all the capacitors to check them. 

SO, again - Any inputs are very welcome - But most important I would like to know, if anybody knows, if the  "A hit the floor" is somehow a trustworthy diagnostic that the error is in that part of the circuit - Or if that could also be triggered by a power leakage in the Arduino chip?

PS. I am thinking about making my own stepper circuit to test the Mega without the Ramps board but just wanted to ask before investing much more time. 


  • I would try to move the motors by hand, not retard strength. if they move and the machine is on (and the motors aren't commanded to off) you aren't getting the holding tourque (ie amps) from your steppers.
  • Hello Mattr254,

    That was a good idea. I tried that. It seems the holding torque is about the same then what it used to be. I did obviously not try to move the the carriages so much while my printer was working so hard to tell.

    I can just lift the corner of the printer up from the ground before the torque give in and the carriage starts to slide. 

    I changed my mind last night and tried to make a hack using a different Arduino (UNO) to control the RAMPS board (instead of making an alternative circuit to test the Mega). But my skills in electronics came up short so it was unfruitful (99% sure it was my hack and not the actual error).   Will go back to the original plan of testing the Mega instead - It looks easier. Also I ordered a new Mega just in case it turns out to be that. I have been wanting to learn electronic troubleshooting for some time, but kinda been on/off it. Now I wish I had been more determined - Then I am sure that I could have troubleshooted this in no time... Oh  well ;) 

Sign In or Register to comment.