Two Kossel Arduino Serial Connects Stopped Working?? Help?

Hi All

So i have a Kossel Clear, running repetier firmware, more than 2 years old now.

I run Repetier Server, and all of a sudden it couldn't connect.
So i try Repetier Host.
It said something like Start Signal not detected, then it would just receive trash data.
Tried re flashing the Arduino firmware, but that didn't help.
Removed the board from the printer, reflashed and used a different cable. Still no luck.

Figuring the board was hosed, i installed a new one.

At this point, I realized that my printer setup on repetier server had gotten trashed.... No idea why.
Needed to download a Repetier Server update anyways, and i read something in the release notes that looked like it could explain the printer setup being trashed in repetier server.
Get the new version up and running.

So i run through setting up the new ardunio and connect with the latest repetier server.
Works for a while, getting all my settings set back up.
Then suddenly, this second board becomes non-response on the serial line as well.
This time, instead of showing trash coming from the board, both Repetier Host and Repetier server show anything at all coming back. Commands from Repetier Host just buffer up, waiting for any sort of response.

Repetier Server and Host are on two different laptops.
So i don't see how its on the computer side.
I can still reload firmware on the both bad ardunios.
I would  have thought the board sends at least a checksum back to the computer when  uploading firmware.

When i plug into the repetier server laptop,  which is a linux machine, i can tell the arduino is actually resetting every 5 ish seconds.
It doesn't seem that is happening when plugged into the windows machine.

Its not a Baud thing, checked that several times, and Repetier Server does scans through all options when you setup a new printer, and that process just timed out never finding anything.

I am still able to print from the SD card. 

Any ideas? 
I',m totally confused and don't want to keep throwing more arduinios at the issue and potentially damage them.

Does it make any sense that the Ramps board is fried and by extension frying the Arduinio Serial Output?

I'm debating trying to replace the arduino, ramps, and stepper drivers all at once. Or i guess im just stuck printing from SD until i buy something new.

Thanks for any help


  • I have now figured out that something is corrupting the eeprom, which makes the serial link not work.
    Reloading now, to figure out whats going on. My eeprom settings were good, so something is somehow corrupting them???
  • So i'm back up and running.
    I tried connecting from the linux repetier server laptop, but it was quickly apparent the EEprom had corrupted again. 
    Tried again but from windows laptop running Repetier Host. All seems well and i'm starting a print.

    Going to try running this way for a while.
    So maybe this is a bug in Repetier Server. (Or i have a flaky USB port on the linux laptop that is somehow corrupting the eeprom? Is that possible??)
  • The 5 sec reset on linux is the server trying to connect. It retries if com port is detected then seems to fail and retry.

    eeprom can not be written directly from serial. Only way is M206 which only gets send when doing changes in eeprom view. Wrong baudrate is in deed a possible reason to not connect. If printer has a lcd you can set it there and store eeprom in lcd.
Sign In or Register to comment.