I'm trying to use the new bed correction features in 0.92. I thought I'd got everything working but then noticed that Z_PROBE_HEIGHT does not seem to be used any more. I use FSRs and the pressure from the hot-end as my Z-probe, so the Z_PROBE_HEIGHT should, in theory, be 0. Because of slight flex in the diagonal rods and/or a small latency in the FSR trigger time, I used to apply a small correction factor, say -0.15mm to the Z_PROBE_HEIGHT setting in EEPROM.

Now that I've enabled bed correction, this value does not seem to do anything for me. I set it to be -10mm  and the nozzle still goes straight down to the bed. I am homing in-between tests.

Is there something I'm missing?

Thanks in advance.



  • That value is only used during probing to compute Z and tilt etc. Changing it afterwards has no effect unless you resend
    G32 S2 to repeat probing.

    Not really sure what you did as you did not write your command sequences and steps so it is hard to follow what to really expect.
  • Ah, apologies.

    What I'm trying to achieve is bed correction using FSR sensors and the hot-end as a probe.

    so (delta printer - Richrap 3DR):

    1. G28 - Home
    2. G131 - Clear Offsets
    3. Position carriages using the M99 commands to selectively disable motors
    4. G132 S1 - Measure and store offset values
    5. G32 - Measure and store autolevel information
    6. G29 S2 - Measure and store bed correction information
    My misunderstanding comes from when the z offset is applied. For some reason I thought it was during print operations, not during calibration, but it make more sense now.

    If I set the z_offset before running the above procedure, is there anything else I need to change? 

    Thanks again for your help.


  • You should do
    G32 S2
    to save tilt.

    and no G29 S2. That makes no sense as it is meant to get an average z height instead of adjusting to bed tilt which G32 does. And G32 is much better, only cartesian printers might want to have no z correction and prefer a median z height instead, which is what G29 is for.

    !!!!Exception!!!! If you have the z distortion feature compiled in, then G29 makes also sense as it reduces the bumps.

    You do this only once or if you think calibration does not match any more. Especially G132 part does only to be done once. G32 might be repeated after a bed change.

  • thanks. I had configured the Z distortion feature in the web configuration tool and downloaded the resulting firmware. Is there an easy way to double-check that the feature is enabled?

    I am hoping that the above procedure only needs doing once or if the bed changes and it sounds like that is right. Now i just need to make sure z height offset is correct before doing the G32, yes?
  • If you start/reset printer you see amoung other infos this

    10:39:15.602 : Info:PowerUp
    10:39:15.606 : Info:Autoleveling enabled
    10:39:15.614 : Transformation matrix: 0.999999 -0.000000 -0.001371 0.000000 1.000000 -0.000229 0.001371 0.000229 0.999999
    10:39:15.619 : zDistortionCorrection:1

    or you should see it if everything is enabled.
    And yes, z height offset needs only configured once. If you later think you should need to go closer/farther away you can simply change z length and rehome instead of probing.

  • Perfect. Thanks a million.

    And thanks for all your hard work and support on all your products, they are great.

    I'll leave a donation as soon as I get paid!

Sign In or Register to comment.