Setting up dual extruders on Ramps 1.4

I am trying to upgrade my printer for dual extruder setup. but i am having troubles of getting the heater for the second extruder up and running.
all the stuff works normal i.e. the thermistor and the extruder motor but only the heater doesn't work.
i swapped the heater with the first extruder and confirmed its working.
i connected my second extruder for D9 output
first extruder for D10 out and the heating bed for D8 output

the heat bed and the first extruder heats fine but the second extruder doesn't

but when i configure the setup in single extruder configuration, where i connect my cooling fan on D9, the cooling fan works fine.

i have attached my configuration also
can someone please help
Thank you !!!


  • Typical error is to still have a fan configured on pin D9 which is also the default fan pin. Disable fan feature or set it to a different pin.
  • Thank you very much !!!!! :)
  • hello,

    how i set it to a differnt pin or how i could disable the fan feature?

    i had set in the configuration.h the line "
    //#define FAN_PIN   4  // Extruder 2 uses the default fan output, so move to an other pin"
    #define FAN_PIN   4  // Extruder 2 uses the default fan output, so move to an other pin"

    could you please help

    best regards

  • /** Should support for fan control be compiled in. If you enable this make sure

    the FAN pin is not the same as for your second extruder. RAMPS e.g. has FAN_PIN in 9 which

    is also used for the heater if you have 2 extruders connected. */


    Is what enables the fan feature using fan pin. Set this to 0 to disable it.

  • Many Thanks!!
Sign In or Register to comment.