Z Movement only up

I set up my Fabricator mini in the new Repetier Host.
Now every Z movement only goes up.
So the homing sends it up, until it bumps into the ceiling. When I send manual commands, whether up or down it moves up.

I tried to invert the Z movement in the printer settings and to set the homing position to 80mm instead of 0.

Anyone got ideas to fix this?


  • If homing already fails it is a firmware config or hardware error.

    Stepper drivers have a pin for direction. If that does not work - either connection broken or chip it will only go in one direction. One simple test is to use socket for second extruder and configure firmware accodingly.
  • Hey, sorry for being quiet.
    I have ever done any hardware alterations on my printer.
    How do I find the pin configurations.

    Also, any idea, why it worked on older versions of repetier?
  • Maybe first try mid height if z can go up/down. Even if it goes wrong direction it should go both direction if you remember that it starts at Z = 0, so move manually so you have place, increase Z see direction, reduce Z see direction. If both go same direction it is a hardware problem. Loose connection, defect driver, defect pin are possible. Essentially everything that has to do with the direction pin.

    Homing/motor settings from older repetier should work. They never changed.
  • No, they didn't.
    I checked with an older version and the same problem occurs.
    So it's hardware, alright. I have no idea how to change a driver or board, let alone firmware. I hoped, I could change a minus to a plus somewere.
    Weird, that it broke at the same time, I changed versions.

    Well thank you for helping. :)
  • If there is a unused extruder socket you could configure firmware to use that as z axis. Then you only need to plug in motor wires there.
Sign In or Register to comment.