Extruder motor does not move


I just finished building my Delta, everything is working fine except the Extruder Motor, I have tested the Ramps board with a test firm ware from marlin, all the motors can work with out any problem, but when I load Repetier, by using both Pronterface or Repetier-Host, I can move all the motors, heat up the head and even demonstrate a print, but Filament motor does not move.

I believe all  Electronics are fine, I think something is wrong in my firmware set up. any idea is welcome. Thanks


  • i too am having this issue, i have checked the extruder motor, by swapping it with x-axis, stepper moves and responds to x commands.
    swapped the stepper board, also good, also checked to see if there was a miss-wired mosfet, all normal

    the printer worked prior to the upgrade to the latest firmware, so i am pretty sure its firmware or settings.

    its a rostock mini pro with an ATMEGA 2650, i retrofitted a z-probe and a hot bed.

    i have run preheat, and temp went higher than 190, still no luck on e-axis

    i have done a ton of tuning and don't want to lose a days work. there seem to be more than a few threads on this type of issue, so i was hoping you might have some insight, i have checked other threads 

    any help would be appreciated.

  • Same here. I can move my 2 extruders from the LCD control panel, but not from Repetier. I've checked steps/mm, it's at 300 for both; other parameters seem reasonable too. The hot end is at temperature and Repetier knows this. I've even tried setting/allowing cold extrusion.
  • edited January 2015
    Heat the hotend to 155 and see if it works - there is an embedded safety parameter for minimum extrusion temperature, not just having the hotend on, but above 150. That made mine work immediately. They stopped working as soon as the temp dropped below 150.
  • In 0,92 you can also send
    M302 S1

    to allow cold extrusion.
  • In my case, it turns out the printer supplier (Boots) is only offering 0.91 and they haven't upgraded yet. Is there anything other than the boot-up logo that would prevent me using 0.92 directly from you?
  • Hi, Thanks all. I suppose I solved the problem some how. just need to enable extruder in Repetier host and then wait until extruder heat up properly.
Sign In or Register to comment.