all endstops showing "hit", no directional movement available

when attempting to move z axis drive to home, lcd display instantly shows endstop hit but z carriage is roughly at +10mm above bed. z axis home position set by endstop is "paper thickness" above bed. no idea how to check since i am noobie to 3d printing. prior to updating to latest host software, computer-printer combination worked fine. sorry, do not remember what old version was, only number i remember was .8something. pc running win10. help file shows Repetier-Host software

   Copyright 2011-2013 Hot-World GmbH & Co. KG, Knickelsdorf 42, 47877 Willich, German

   Licensed under the Apache License, Version 2.0 (the "License");
   you may not use this file except in compliance with the License.
   You may obtain a copy of the License at

possible assistance?


  • additional info---   z axis endstop bolt loose, switch open, no contact between bottom end of bolt and switch lever.
  • Host does not handle endstops, it is your firmware that handles it. So if they are not triggered (M119 shows all H) you need to change firmware config for endstops. If they go low when triggered just invert logic.
  • thank you for the tip...  tried and got it set now... kudos
Sign In or Register to comment.