Z max endstop issues

I have a Z max endstop set up on my printer. The entire homing routine works fine, but when I check what the printer thinks its Z position is afterwards, it says 300mm. From what I have read, shouldn't the printer assume it is at Z_MAX_LENGTH after it hits the endstop? I have this value set to 95 - nowhere near 300.
I am using Repetier Firmware with a RADDS board.


  • if you are talking about what Host shows after homing , be shure that Printer settings in Host match Firmware settings.

  • I was talking about what the firmware shows after I request the toolhead position. I have the Z height set to 95 in the host as well.
  • Host also has a field homing position that you need to set to 95!
  • Sorry, should have clarified; I am using Cura, and I don't see a setting similar to the one you mentioned. I was under the impression that you could use a Z max endstop regardless of the host you used.
    Would I have to use Repetier-Host for this configuration to work?
  • I don't know why Cura shows what. That should not prevent printer from printing files. Homing still works just position cura thinks is wrong but absolute coordinates will still move correctly.
  • Unfortunately this is preventing me from printing files. Homing to the endstop works correctly, but the printer still thinks it has to move 300mm before the print starts.
  • I have switched to Repetier-Host just to make sure it isn't a host issue.
    I homed the z axis, and as the axis moved it showed the position as 95mm. Then it hit the endstop, at which point it jumped to 300mm again. I pressed "set home" and position went back to 95mm, but this reverted to 300mm after I homed it again.
    Because each print starts at z = 0mm, the printer believes it has to move from 300mm all the way to 0mm, and runs into the top of the z axis when it tries to accomplish this.
    Hopefully you can point me to a firmware setting or M code that can help troubleshoot.
  • Check your eeprom values.
    z min = 0
    z length = 95

    is what it should say.
    should show Z 95 then. Maybe you have not updated eeprom and only configuration.h?
  • Sure enough it was the EEPROM values that were causing the error.
    I figured out how to set the Z max value, and now the printer comes to a stop when it should.
    I remember on my Marlin firmware, you could change the configuration.h file and it would overwrite the EEPROM. Is there a setting in Repetier-Firmware that would allow me to do this?
  • Send to priinter
    this will read values from config and store into eeprom
  • Awesome, the M502 is super helpful.
    Thanks all for the information!
Sign In or Register to comment.