New to 3d printing / Repetier host

question - I just finished putting together a oneup from q3d - say what you will it taught me alot - however, trying to correct some 'banding' on the sides of my prints I replaced the z axis threaded rod with a 8MM lead screw - now the printer moves like 30mm for every 10mm I say in the manual control of repetier.  As I am new to printing - I am still trying to work the bugs out (and if anyone knows is q3d out of bidnezz or? cause they don't respond at all) I posted here because I don't even know where to start looking let alone searching. (and I am pretty sure this won't be my last question either <span>:smiley:</span> )


  • you need to change the Z axis steps/mm to suit the pitch of the lead screws.
    Most of the lead screws you buy are whats called '4 start leadscrew' so at 1/16th microstepping you will need 
    steps/mm = 400. you can set this directly into the eeprom using repetier host eeprom editor.

  • thank you - hopefully this will work I will try it in a few hours!!!!! <span>:wink:</span>
  • okay - so I tried this - first set it to 400 and it seemed to have no effect at all - then tried 800 and eventually 1600 with no apparent change -- here's the sticky bit - when I disconnect and reconnect it reverts to 88.6 or whatever it was.  should I be doing something other than 'save to EEPROM'?  - I do have the .INO file and arduino IDE loaded - should I be changing it somewhere in there?
  • Alrighty I am a fool  - it would help if I put the 400 in the right place - seems to be working now - now if it will just start printing and not  saying heating extruder
  • my next question is why does that setting not stay - I was messing with setting my home and it reverted back to the original setting  - then I set it again - started the print and now it seems to be working - do I need to set this every time I print something?
  • What firmware are you using? Do you have eeprom enabled in firmware, which is required to store changes.
  • it is modified marlin firmware from what I gather - if you are curious you can look at click the oneup - then it is the 'steel gear firmware'

  • you could try setting the steps/mm by sending to the printer
    M92 Z400  ;sets Z steps=400
    M500        ;stores value to eeprom if enabled

  • Thanks Martin - will try that - all this mucking around I released the 'magic smoke' from my thermistor LOL! gotta order another 
  • I <3 the 'gcode' Martin - and it helps as I think the revision of marlin I have doesn't allow eeprom updates - HOWEVER - I did fine where it is hardcoded in the .INO file (*DEFAULT_AXIS_STEPS_PER_UNIT*) so - going to order another mega and upload it see if that fixes that problem.   

    The thermistor went fine - and now repetier is happy with my printer.  

    Another question I have is - my filament isn't getting jammed per se however it isn't staying in the hotend  during the print - it like spews out the side before it gets to my hotend - kinda like the motor is too fast - I have it set to .98 in the slicer config - it just doesn't seem to want to take - before I replaced my zaxis threaded rod it had to be at 1.1 to print anything - so weird - I don't even know what to call that type of thing as it isn't a jam - I just cut the filament pull the wrinkled filament out and start a new one - this however messes up my print every time and I can't even print something (say a 20mm dome 30 minute print) before I get another jam.

    any ideas?
  • Do a google search for the QU-BD OneUp forums. they are still out there.

    My first printer was a OneUp. There are a lot of mods you can do. Limit switches (endstops) are a must in my opinion.Different hot-end is recommended also.

    I had all the links but I deleted them a long time ago.

    I think I am straying off topic for this forum so I will stop.
Sign In or Register to comment.