Layer Shift Problem.

edited June 2017 in Repetier-Firmware
I use Repetier-Firmware 9.2 on my i3 machine , and use Repetier-Host to Control.
When I print 3DBenchy to test , X always contains some layer shift in random layer.
I check belt , motor , electronic system ...etc and I can't find how it occur.
Print speed is not very fast , Only 30mm/s , travel speed slow down to 60mm/s , problem still happen.
Finally , I use marlin to control , configurations are the same , the problem is solved.
Is there any idea or what information I can provide to improve this problem?

My control board is MKS Gen V1.4 , Moto driver = LV8729 + 1/64 microstepping  


    If you have crosstalk from endstops this can also cause a stop in direction and this happens more often then you think. So disabling the test prevents this type of shift.
  • edited June 2017
    Problem seems to be solved
    Thanks for help!!:D

  • Where do I find this setting to correct it?
  • Configuration.h as all settings.
Sign In or Register to comment.