Autolevel issues

I have my z probe setup working.

But I still have issues with the height of the first layer.

I have done the G32 S2, and after making sure the level is as physically as level as possible. A test with probing in different locations is quite good (paper under nozzle).

However when printing some arreas the nozzle is to high (no adhesion) in other the nozzle touches the bed (no extrusion on bed).

Could it be that the correction is done mirrored or in the wrong direction?

I will recompile my firmware to add z distortion so i can add it to the correction...


  • You probably have high's and low's in the bed surface, G32 will only compensate for  a 'flat' non levell bed.
    You may need to use G33 'distortion matrix levelling.
  • Ok I will give it a try this evening, how big should I make the grid?

    (I'm using a prussa i3 clone)

  • When i was using a alluminium bed, it had about a 0.5 mm hump in the middle of the bed when it heated up.
    I used a 6x6 grid which seemed to help. I ended up fitting a sheet of glass in the end tho,now nice and flat :)
  • I have a glass plate but it is to thick for the detection rang of the z probe.

    Could I do the autolevel correction and home, and then place the glass and add the offset for the glass plate in the slicer for instance?

  • Ben3D said:

    I have a glass plate but it is to thick for the detection rang of the z probe.

    Could I do the autolevel correction and home, and then place the glass and add the offset for the glass plate in the slicer for instance?

    That could work i think.
    My glass is so flat atm i dont need to use ABL, just manually adjusted the screws to get the bed as levell as possible and printing 3DLABS aeroplane sections across the whole bed surface perfectly.
    I did fit a BLtouch probe when i fitted the glass, but i dont need to use it <span>:smiley:</span>
  • If you have z-max homing that is no problem. You can set bed coating to glass thickness and tell firmware that you measure till bottom excluding coatings. That will even correct height when homed.
  • Don't have z-max homing currently, but I plan to use my old z min end stop for as a z max switch.

    Only need to figure out how to mount it...

  • Does the G33 command uses the probe offset ad inputted in the Zprobe sections?

    The grid is defined in nozzle positions it seems
  • G33 uses same z probe height offset. For this it is important to have it correct and not have tricked with z position after G32 S2, e.g. changing z length with max homing means G32 can not be trusted any more.

    Grid are nozzle positions yes, but measured by z probe so must be reachable with nozzle and probe active.
  • If you notice when you do a G30 at 0,0 ,your effector moves over to the offsets you input so the probe measures the 0,0 point. The same happens with the rest of the grid coordinates. Like Repetier said the grid coordinates must be reachable (safely), off-setted nozzle and probe.
  • G30 command show an expected X and Y offset correction
  • And also worth nothing is that after a G32 S2 command, i do a test with probing the bed and do a paper test on the nozlle, the paper get touched at Z at 0.1 mm in a spot when i start my printing action it is pushing the nozzle to the ben (with a first layer height of 0.2mm).

    It just does not make sense...

  • is it ok for me to after taking the G32 S2 do a home using G28 before starting the print?
  • Yes G28 uses autolevel from last G32 S2 so yo only need G32 S2 if you changed something that changes bed rotation.
  • Did a new setup, removed the springs under the bed. leveled it and did a grid autolevel measurement:
    12:30:36.266 : Info:Autoleveling disabled
    12:30:44.620 : Z-probe:4.236 X:20.00 Y:20.00
    12:30:50.710 : Z-probe:4.247 X:20.00 Y:53.75
    12:30:56.835 : Z-probe:4.263 X:20.00 Y:87.50
    12:31:02.995 : Z-probe:4.321 X:20.00 Y:121.25
    12:31:09.219 : Z-probe:4.401 X:20.00 Y:155.00
    12:31:16.297 : Z-probe:4.138 X:55.00 Y:20.00
    12:31:22.328 : Z-probe:4.149 X:55.00 Y:53.75
    12:31:28.361 : Z-probe:4.151 X:55.00 Y:87.50
    12:31:34.410 : Z-probe:4.182 X:55.00 Y:121.25
    12:31:40.498 : Z-probe:4.231 X:55.00 Y:155.00
    12:31:47.517 : Z-probe:4.042 X:90.00 Y:20.00
    12:31:53.497 : Z-probe:4.083 X:90.00 Y:53.75
    12:31:59.479 : Z-probe:4.085 X:90.00 Y:87.50
    12:32:05.472 : Z-probe:4.098 X:90.00 Y:121.25
    12:32:11.491 : Z-probe:4.136 X:90.00 Y:155.00
    12:32:18.471 : Z-probe:4.013 X:125.00 Y:20.00
    12:32:24.408 : Z-probe:4.010 X:125.00 Y:53.75
    12:32:30.373 : Z-probe:4.051 X:125.00 Y:87.50
    12:32:36.352 : Z-probe:4.081 X:125.00 Y:121.25
    12:32:42.336 : Z-probe:4.088 X:125.00 Y:155.00
    12:32:49.417 : Z-probe:4.145 X:160.00 Y:20.00
    12:32:55.428 : Z-probe:4.118 X:160.00 Y:53.75
    12:33:01.413 : Z-probe:4.090 X:160.00 Y:87.50
    12:33:07.437 : Z-probe:4.129 X:160.00 Y:121.25
    12:33:13.468 : Z-probe:4.152 X:160.00 Y:155.00
    12:33:13.472 : plane: a = -0.0013 b = 0.0006 c = 4.2071
    12:33:13.481 : Transformation matrix: 0.999999 0.000000 0.001301 0.000001 1.000000 -0.000634 -0.001301 0.000634 0.999999
    12:33:13.483 : CurrentZ:4.21 atZ:4.13
    12:33:13.485 : Info:Autoleveling enabled

    The result is quite good i think.

    But when i start a print still the left side X 20 to 100 is the nozlle to close to the bed!!!

    It is just nog doing what it should do, or is there somethnig else worng?

  • Check bending correction is all set to 0. Except if your z probe puts force on bed then set it to expected bending at the measurement point but then you can not do grid leveling as bending correction only works correct if there are only 3 points or some very special conditions.

    Of course you can also add bending correction for x 20 so it adds some more at that side to compensate the error.
Sign In or Register to comment.