Manual lowering of hotend

i recently used the repetier firmware configuration tool and i have lost a feature that was very useful. in the past when i pressed the hotend down key (-10) for the first time, using repetier host , the hotend would lower itself to 180 mm, and every other pressing of the down key(-10) the hotend would lower by 10, my Z max length is 208.1. With the new firmware when i press the down key (-10) for the first time, the hotend lowers to 198.1, is there a way to set something to lower the hotend to 180, after the first pressing of the down key?


  • Hope you have already 2.0.1 installed. There you can set in printer settings the homing coordinates. That is what host assumes after homing. Then Z-10 should always move down 10 more. Problem is that host does it relative so if you lie on homing position the -10 is also wrong. If it was really 180 befor I think your old homing had Z position 190 and reported this to host. For some compatibility reason we do not scan the reported position any more and use the stored value now.
  • Hi thank you for the quick response.  However i think i may not have explained the issue properly. i have created a video on youtube, hopefully this will explain the issue better.
  • So it did it wrong and now correct and you want the wrong version back:-) No idea why it did this wrong but since it is now working as intended I will do nothing.

    You can set one script to do this. Set it to
    G1 Z180 F6000

    by right clicking the script button.
Sign In or Register to comment.