XYZ motors not moving when printing

Hi, I'm having some issues with my DIY delta printer. The configuration is: Arduino Mega, RAMPS 1.4, DRV8825 with Marlin firmware.
I can control every motor with the manual control, homing works fine, and also g-code positioning. Also works fine with my extruder (ceramics extrusion, but this doesn't matter at all). Both sliders and extruder are calibrated properly.
The problem I'm having is when launching a print (with no material and to test if goes ok) the head goes to the starting point, prints the brim layer but doesn't go forward (extruders keeps on rotating, but printer is not moving). Don't think is a problem of the Marlin, all calibration settings are ok. I'm wondering if is the g-code, but tried different ones and did the same. 

Here some hits that could help you:
-Motors are powered when the print is not running
-Currents are set at their correct value
-I have some g-code at the start-end of every print (this shouldn't be a problem because is just regarding homing and absolute values).
-I'm not using the latest version of Marlin. I had some troubles with it so I went straight with the one I knew would work.
-I can see that Repetier is sending g-code when the print should be running, but doesn't move.

Please, feel free to ask. I have searched lot of info but couldn't figured out the problem.
Thanks in advance


  • If you see extruder is moving and it is sending the move g-codes which is the reason extruder moves I guess it is a firmware issue. You could check M119 if all endstops are triggered which might prevent moves in the triggered direction. If it is a marlin version supporting echo you can enable that to even prove commands with move were received.
  • Endstops are not triggered. About the echo, ill figure out how to enable it and let know.
    Think updating the firmware could be an option? (latest one didn't work properly, but can try one in between) Or is not worth it?

  • I don't follow marlin changes so closely to say if it is worth. Enabling echo is in host easy mode off then in manual control you have the debug options at the bottom.
  • Hi, I checked the echo option. When the print is running (but not moving) I dont have any message in the box like "echo: .....". Just when I stop the print I got some Echo messages regarding to PID values, Max acceleration, Endstops ajustments...
    I also tried the latest firmware but the printer gets completely crazy (not even homming). I will keep on checking if all fmwre settings are ok in last marlin version.

    Hope this information helps you
  • No idea what is happening here. Sure you were viewing complete log and not disabled commands/ack?

    If no commands are going through it might be waiting for extruder to heat up. Slicers add such gcode normally.
  • Here is the echo I get when printing (ack is enabled):

    11:13:39.685 : X:0.00 Y:0.00 Z:250.00 E:0.00 Count X:24484 Y:24484 Z:24484
    11:13:39.685 : ok
    11:13:39.685 : echo:N14 G1 Z15 F0*53
    11:13:39.685 : ok
    11:13:39.685 : echo:N15 M107*17
    11:13:39.685 : N22 M117 ETE -55s*30
    11:13:39.685 : ok
    11:13:39.685 : N23 G92 E0*118
    11:13:39.685 : echo:N16 G90*39
    11:13:39.685 : ok
    11:13:39.685 : echo:N17 M82*47
    11:13:39.685 : ok
    11:13:39.685 : N24 G1 Z-140.8 F6000*10
    11:13:39.685 : echo:N18 G92 E0*126
    11:13:39.700 : X:0.00 Y:0.00 Z:15.00 E:0.00 Count X:24481 Y:24481 Z:24481
    11:13:39.700 : ok
    11:13:39.700 : echo:N19 G21*34
    11:13:39.700 : N25 G1 E-2 F2400*5
    11:13:39.700 : ok
    11:13:39.700 : echo:N20 G90*34
    11:13:39.700 : ok
    11:13:39.700 : N26 G92 E0*115
    11:13:39.700 : echo:N21 M82*42
    11:13:39.700 : ok
    11:13:39.700 : echo:N22 M117 ETE -55s*30
    11:13:39.700 : ok
    11:13:39.700 : echo:N23 G92 E0*118
    11:13:39.700 : N27 G1 X53.414 Y-20.504 F6000*85
    11:13:39.700 : X:0.00 Y:0.00 Z:15.00 E:0.00 Count X:24477 Y:24477 Z:24477
    11:13:39.700 : ok
    11:13:39.700 : N28 G1 E2 F2400*37
    11:13:39.700 : echo:N24 G1 Z-140.8 F6000*10
    11:13:39.700 : ok
    11:13:39.700 : echo:N25 G1 E-2 F2400*5
    11:13:39.700 : N29 M204 S200*95
    11:13:39.716 : ok
    11:13:39.716 : echo:N26 G92 E0*115
    11:13:39.716 : X:0.00 Y:0.00 Z:0.00 E:0.00 Count X:24471 Y:24471 Z:24471
    11:13:39.716 : ok
    11:13:39.716 : N30 G1 X54.352 Y-18.061 E2.56986 F3000*20
    11:13:39.716 : echo:N27 G1 X53.414 Y-20.504 F6000*85
    11:13:41.732 : echo:busy: processing
    11:13:43.748 : echo:busy: processing
    11:13:45.760 : echo:busy: processing
    11:13:47.776 : echo:busy: processing
    11:13:49.776 : echo:busy: processing
    11:13:51.792 : echo:busy: processing
    11:13:53.808 : echo:busy: processing
    11:13:55.826 : echo:busy: processing
    11:13:57.842 : echo:busy: processing
    11:13:59.858 : echo:busy: processing
    11:14:01.876 : echo:busy: processing
    11:14:03.888 : echo:busy: processing
    11:14:05.897 : echo:busy: processing
    11:14:07.911 : echo:busy: processing
    11:14:09.442 : ok
    11:14:09.442 : echo:N28 G1 E2 F2400*37
    11:14:09.442 : N31 M117 ETE -55s*28
    11:14:09.442 : ok
    11:14:09.442 : echo:N29 M204 S200*95
    11:14:09.442 : N32 G1 X54.587 Y-17.336 E2.73587*121
    11:14:09.442 : Setting Print and Travel Acceleration: 200.00
    11:14:09.442 : ok
    11:14:09.442 : echo:N30 G1 X54.352 Y-18.061 E2.56986 F3000*20
    11:14:09.505 : ok
    11:14:09.505 : echo:N31 M117 ETE -55s*28
    11:14:09.505 : ok
    11:14:09.505 : N33 G1 X55.942 Y-12.28 E3.87567*65
    11:14:09.505 : echo:N32 G1 X54.587 Y-17.336 E2.73587*121
    11:14:09.505 : N34 G1 X56.101 Y-11.535 E4.04164*123
    11:14:09.536 : ok
    11:14:09.536 : N35 M117 ETE -55s*24
    11:14:09.536 : echo:N33 G1 X55.942 Y-12.28 E3.87567*65
    11:14:11.538 : echo:busy: processing
    11:14:13.554 : echo:busy: processing
    11:14:15.570 : echo:busy: processing
    11:14:17.587 : echo:busy: processing
    11:14:19.604 : echo:busy: processing
    11:14:21.620 : echo:busy: processing
    11:14:23.698 : echo:busy: processing
    11:14:25.704 : echo:busy: processing
    11:14:27.720 : echo:busy: processing
    11:14:29.731 : echo:busy: processing
    11:14:31.747 : echo:busy: processing
    11:14:33.794 : echo:busy: processing
    11:14:35.804 : echo:busy: processing
    11:14:36.148 : ok
    11:14:36.148 : N36 M117 ETE -55s*27
    11:14:36.148 : N37 G1 X56.919 Y-6.366 E5.18141*68
    11:14:36.163 : echo:N34 G1 X56.101 Y-11.535 E4.04164*123
    11:14:36.991 : ok
    11:14:36.991 : echo:N35 M117 ETE -55s*24
    11:14:36.991 : N38 M117 ETE -55s*21
    11:14:36.991 : ok

    Is that busy processing normal? I can feel that in these moments the extruder motor in vibrating (trying to move) but doesn't do it at all. 
    Also I give the echo I get when I cancel the print:

    11:14:39.132 : echo:Steps per unit:
    11:14:39.132 : echo:  M92 X35.56 Y35.56 Z35.56 E164266.67
    11:14:39.132 : echo:Maximum feedrates (units/s):
    11:14:39.132 : echo:  M203 X100.00 Y100.00 Z100.00 E25.00
    11:14:39.132 : echo:Maximum Acceleration (units/s2):
    11:14:39.132 : echo:  M201 X9000 Y9000 Z9000 E10000
    11:14:39.148 : echo:Acceleration (units/s2): P<print_accel> R<retract_accel> T<travel_accel>
    11:14:39.148 : echo:  M204 P3000.00 R3000.00 T3000.00
    11:14:39.148 : echo:Advanced: S<min_feedrate> T<min_travel_feedrate> B<min_segment_time_ms> X<max_xy_jerk> Z<max_z_jerk> E<max_e_jerk>
    11:14:39.148 : echo:  M205 S0.00 T0.00 B20000 X20.00 Y20.00 Z20.00 E5.00
    11:14:39.148 : echo:Endstop adjustment:
    11:14:39.148 : echo:  M666 X0.00 Y0.00 Z0.00
    11:14:39.164 : echo:Delta settings: L<diagonal_rod> R<radius> H<height> S<segments_per_s> B<calibration radius> XYZ<tower angle corrections>
    11:14:39.164 : echo:  M665 L568.00 R361.00 H250.00 S200.00 B159.00 X0.00 Y0.00 Z0.00
    11:14:39.164 : echo:PID settings:
    11:14:39.164 : echo:  M301 P22.20 I1.08 D114.00
    11:14:39.304 : N1 M110*34
    11:14:39.304 : N2 M115*36
    11:14:39.304 : N3 M105*36
    11:14:39.304 : N4 M114*35
    11:14:39.351 : N5 M111 S7*99
    11:14:39.351 : N6 T0*60
    11:14:39.351 : N7 M80*28
    11:14:39.430 : ok

    Hope you have more info now.

  • Busy processing just is the firmwares way to say: I'm doing something so do not bother if I do not respond directly.
    So that is ok. It also shows host is doing his job correct sending the moves. Motor shaking is your problem I think.  YOu see at one point acceleration was set to 200. I don't know what your printer can handle but sinc eit works at startup 200 might be too much also this is normally a low value. Most printers can print with 2000-3000 for xy also printer shakes a lot then.
  • Yes, it seems that the problem is with the extruder motor shaking and vibrations. I have changed and tried other accelerations but didnt get any thing in clear. Which are the normal values of acceleration and feedrate?
    Now I realised that the XYZ sliders move but very very slowly (you cannot barely see unless you do a scratch in the frame). This could be because of printing speed? Didn't find any information about how to set it up.
    Thanks for your help.
  • Beld driven system can reach 100-200mm/s speed and 2000-7000mm/s^3 acceleration. If it is rod driven like cnc machines it is much lower. Important is also to set steps per mm correct in accordance to pulley and microstepping. Our repetier-host has a calculator for this. So if it just moves very slow steps might just be too low.
  • Hi, I kind of solve the problem, it seem it was some mistake in the steps/mm conversion. The issue I'm having now is that I've been trying to adjust the height to print in the build plate (and not in the "air"), but when homing it just go slightly bit up and stops because doesn't find the endstoppers. Also is skipping some steps (current of motors is 100%, cannot go further). 
    The height issue might be because of the distance set in repetier and marlin. Regarding to repetier, in version 2, it requires two different heights: printer height and Zmax, what is the difference?
    On the other side, I have no clue what could happen with the skipping steps, any idea?

    Thanks in advance
  • Host settings are just a clone of firmware settings so it known your printers dimension. Important for homing is to configure firmware correct. Host has no zmax ony home Z = z after z homing and printer height.
  • I have changed the values from firmware (also from repetier) but still doing weird things when homing. Is like if just goes few centimeters up looking for the end stoppers but never find them. Was working some days ago but now, randomly, doesn't works. Still not finding where that problem comes from. Any clue?
  • z axis with rods? These have often very high steps per mm, not a slow as x and y but more 2400 or more depending on steepness of lead screw, substepping, motor resolution.
  • Just wondering......
    What type of extruder are you using to have 164k steps/mm

    "echo:  M92 X35.56 Y35.56 Z35.56 E164266.67"

  • MartinH said:
    Just wondering......
    What type of extruder are you using to have 164k steps/mm

    "echo:  M92 X35.56 Y35.56 Z35.56 E164266.67"

    Is a clay extruder of 90mm in diam through a nozzle of 1.4 (that's why that huge number).
    Anyways I think I isolate the problem of homing: seems that my ramps board is not working propperly because the endstoppers switch on/off randomly. And If I disconnect from power the ramps and just try the pins with arduino, they work perfectly. So I'm going to change the ramps and let's see if now (finally) works.
    Now printer seems is working fine except for one issue: skipping steps.
    I set the maximum current though the drivers (cannot go further), the only thing I have in mind regarding to the problem is the speed. Are lower speeds significantly better for avoiding skipping steps?
    What could be other reasons to solve it?

    Thanks in advance!
  • Skipping steps can come from jerk being to high, acceleration to high and speed to high. Depends when they loose steps. If speed is < 100 for xy it is normally jerk.
Sign In or Register to comment.