Set temperature with filament settings

Hello. I have been using repetier-host for about a week and I'm loving it!
I have tried to add filament settings, with both nozzle and bed temperatures, but they always revert to 210 on the nozzle and 50 on the bed.
Then I have to change it once the print has started with the help of manual control.
I'm running default g-code:
; Default start code
G28 ; Home extruder
M107 ; Turn off fan
G90 ; Absolute positioning
M82 ; Extruder in absolute mode
; Activate all used extruder
{IF_EXT0}M104 T0 S{TEMP0}
G92 E0 ; Reset extruder position
; Wait for all used extruders to reach temperature
{IF_EXT0}M109 T0 S{TEMP0}

Thanks for any help



  • the 'BED'  and the 'TEMP0' in your start code read the bed and nozzle temps you have used in the slicer settings
  • I have 2 filament profiles, one default which is 210 on nozzle and 50 on bed. Then I have the one I want to use, 200 och nozzle and 63 on bed. It seems that it runs on the default even if I pick the 200 63 setting, since that is the only place in repetier where it says 210, 50. Might be a bug?
  • Only in old host versions. There was in deed a bug not selecting the shown filament. But just to be sure - you have selected the filament in the right tab and not left one?
Sign In or Register to comment.