Nozzle digging on larger prints

1st this is on a Kossel Mini.

When I try to print larger parts, like say a case for my board, the hotend nozzle digs into the bed on the outer edges. Small Prints are fine though as they are in the center. I am a bit perplexed on this issue as I have set my Z Height right to where when I go the zero point in all sides of the bed they are the same distance above the bed. A thickness of a piece of paper. So basically right in front of each tower the 0 height is the same when I go to it just as it is when I go to the center.

I am wondering if my Z Probe Offset is wrong and causing the printer to dig into the bed. The original Firmware has it at 0.8 for the Z Offset. This is a mechanical endstop and it is using the Nozzle as the probe. I have changed the effector since then but the way it works a how you adjust endstop are the same. So I originally thought the measurement should be the same as I follow the smae procedure when adjusting the screws for it. But now I am wondering if I am wrong and if the Offest might have changed when upgrading the effector. So in turn when I use the G29 command that it is calculating the wrong heights for when it prints.

I should also mention that I am printing with no heat to the Print Bed as well. 

Could this issue be my Z Offset?
If so, is there a way in which I can figure out what my Z Offset should be?

I am thinking that my Offset should be the distance traveled by the actual switch press. So from the point when the head makes contact and starts to press on the switch to the point when the switch clicks reading the trigger change. Is that correct?

Any help would be appreciated. Thanks :)

Hope this hyperlink works. This is just a pic of the effector I am using so you can see the type of probe setup I am using.
Pic Of Effector


  • What firmware are you using? Repetier firmware uses G32 for heights computation.

    On deltas such problems often occur if you go to the outside while it works in the center region. Often problems start when crossing the connection between towers. These are simple geometric errors in mechanic or wrong calibration. Calibration works by optimizing the measured points. Points outside are not seen so not considered and might even get worse.

    If you can not fix this with changing some geometry variables you might want to use distortion map for this. If you only fill in corrections manually you can make it even cover the complete printer in repetier-firmware. If not only the reagion reachable by z-probe.
  • edited April 17
    I am using Marlin RC. In the files it the Version.h says it is "1.1.0-RC8".
    I tried using the Repetier Firmware Tool for my Kossel but it became very confusing after and the printer got all messed up when using it. I found just editing the Marlin Code manually to be a lot easier for me for some reason.

    On a side Note. I do think that it would be nice if there was a set of official tutorials for your configuration tool. I was only able to find two tutorials online neither of which dealt with a Delta/Kossel setup. But I digress.

    On the part about going outside the points when probing, that makes a lot of sense. I had to tweak the settings in the firmware to get the probe to certain range. When I first tried it the effector went pretty far out and was rubbing up against the towers. It was set to -10mm off the printable radius. I changed that to -40mm off. This line below.


    I have my Printable radius set to 100. The advertisement for the printer said 220mm but that is false as that is just the size of the build plate. That safest diameter with good clearance from the towers is 200mm, minus any oversized fan you may have attached. Which I have. LOL :) That is why I changed it from -10mm to -40mm. I'll try to tighten that up a bit until I figure out a different fan design. :)

    On the Distortion Map, my Repetier host has that greyed out. I have been wondering how to get that to work. Is that tied to G32?

    I have not used G32. I have only been using G29 as my original Firmware did not support G32 so I sort of forgot all about that after reading about it a while back. I think I'll try that next as my new firmware I just updated to does support it.
    EDIT: It seems that G32 is doing nothing for me. It is listed as one of the commands in my Marlin_main.cpp BUT it seems to say (Z_PROBE_SLED only). I am using a Fixed_Mounted_Probe. So I guess that option is out for now. :(
  • In host it is just measuring a height map, but that only works with repetier-firmware whcih is why it is greyed out.

    G32 is the autoleveling from repetier whcih is in marlin G29.
Sign In or Register to comment.