Delta "un calibrates" during print

Hi there,

I have just installed repetier firmware on my delta 3d printer.
After doing all the calibrations and fixing the inevitable issues of using a new firmware, i ran into something very odd.

I managed to print a small part for the printer which was a 15 min print and it worked fine. Now i am printing a larger piece, and for some reason after the first couple of layers of printing, the printer seems to de-calibrate. The effector starts moving way off the lines it has previously been printing over and also starts to move away from the build surface. I have managed to video the print whilst this happens and i will try to find a way to upload it.

Any help is much appreciated,



  • It is not decalibrating, it is loosing steps. Maybe because the endstop trigger from crosstalk. That happens sometimes and can be prevented by setting ALWAYS_CHECK_ENDSTOPS 0 in firmware configuration. It might also loose steps be hitting something, accelerations/jerk being to fast for motors.
Sign In or Register to comment.