Extruder heaters not turning on and extruder motor not turninig

i have just installed your firmware on a MPX.3 printer controller board and also installed dual extruders but the extruders will not turn on i have them plugged into extruder plug 0 and 1 but then I turn on the extruders manually in the client software.
the heaters don't heat up and they turn off on the software after a few seconds.

in the firmware i have them set as the default sockets and i have them plugged into the default sockets and when I test the power from those sockets i got no voltage coming to them after a try and turn them on manually with the repetier software.

it's like the board is not responding to the commands.
here are some images from my set up


i am putting the red waxy cables into the top green block e0 and e1 in the image below they were removed to test for a voltage on activation in the software and no voltage was detected


I'm not sure why it just started to play up but on a single extruder it was running marlin and worked ok
I just thought I could get better control using your firmware

I tried selecting Mega/RAMPS up to 1.2 and also RAMPS1.3/RAMPS1.4 none of the options make a difference to this.

the AXIS control now works fine XYand Z Auto level works great just no heating ability at all


  • Use M302 S1 to allow cold extrusion for motor testing.

    Reagarding board, this is not a RAMPS from the look so maybe pin numbers are not 100% compatible. Ramps has no dedicated FAN output so E1 output is used for fan as well and only one may be active. You can always use the official digital pin number instead of HEATER_xx so you know it uses right pin.
  • From marlin github

    #undef HEATER_BED_PIN
    #define HEATER_BED_PIN    8    // BED
    #undef FAN_PIN
    #define FAN_PIN           9    // FAN
    #undef HEATER_0_PIN
    #define HEATER_0_PIN     10    // E0
    #undef HEATER_1_PIN
    #define HEATER_1_PIN      7    // E1
  • Yes, looks liek the board. So MPX3 is only nearly compatible. Will add a extra board for it.
  • Ok, dev version now has the MPX3 board.
  • Hi, I have similar problem with MPX.3... After using DEV version and selecting MPX3 board, heating does not function - looks like sensor error. Stabile firmware version functioned well, but I had problems with printing circle. Do you have sample config for this board, please? Thanks, Ota
  • I even don't have the board :-)
    All I changed in MPX3 compared to RAMPS is setting output pins different. Input pins were not changed. What board did you use for stable? Sure input settings are identical?
  • i have not had a stable working on this. I just thought once i  upgraded to the new E3d stuff I could use the firmware as I could never get it working with the old set up

    I can get the bed heating up at the mo but I can not get the thermistor detecting the temp 
  • even if a select the thermistor recomended by E3d i am showing a temp of -12 at the mo using the dev vesion
  • i give up i can not get this MPX3 board to work.
    since i have bought this sainsmart.com board THC_RAMPS_3D V1
    is there a board selection that will work in the firmware config.

    i might have a better chance with this board
  • What thermistor did E3D recommend? As I said if it is a thermocouple you can not use the thermistor inputs which have a 4.7K resistor in addition and that does not work with thermocouple.

    From the name I guess it is simple RAMPS clone also googling gave me 0 results.
  • i have now got my hot end to heat up but now the extruder will not feed and also
    i have had to disable my heated bed for now as I cant get that to detect a temp it will heat up but the thermistor is not detecting any heat
  • What they mention is a normal thermistor. So it may just be that the pins are in wrong order. If you have all connected you could try to heat one and see which temperature is going up and if that is the same device (bed/extruder) or a different one. Often it already ok to test by hand warming the sensor. If you unplug a sensor you could also measure the resistance. At 25°C they should have around 100kOhm.
  • edited April 27
    I can heat the hot ends up but the temp starts at -22 if i leave it it will rise to 200

    but the bed is showing 33 degrees and wont move from there no matter how hot it gets

    so i know its not ideal i have to turn the hotbed on manually then turn it off once everything seems fine with the print normally at slice 4 or 5

    it must be the pin number but i just cant seem to find the correct one

    from the image above the bed thermistor is the yellow cable 
Sign In or Register to comment.