Z stepper motors move only one direction

Just completed building a RepRap Prusa I3 printer for my son.

Had no problems with the build and I tuned all the stepper motors to .550

Inputted all the settings info from Reprapguru instruction manual into Repetier software and then tried to manually control stepper….this is when the problems started.

Both Z stepper motors will only move in a clockwise direction.  And the X stepper motor when I turned on the first time would move in both directions until I hit the X home button.  Now it will only move in one direction as well.

I’m new to this and really don’t have a clue, but reading post for a couple of hours I’d say I have an issue with my endstops?  If I input code M119 I get the following:

09:04:46.020 : Reporting endstop status
09:04:46.020 : x_min: open
09:04:46.020 : x_max: TRIGGERED
09:04:46.020 : y_min: open
09:04:46.020 : y_max: open
09:04:46.020 : z_min: open
09:04:46.020 : z_max: TRIGGERED

When I try to move the X or Z away from home position via the manual controls in Repetier I get the following error code (it is basically different measurement every time):

08:12:40.150 : echo:endstops hit:  Z:-0.30
08:12:51.353 : echo:endstops hit:  Z:-0.60
08:13:02.010 : echo:endstops hit:  Z:-0.66
08:13:12.432 : echo:endstops hit:  X:0.00
08:13:31.793 : echo:endstops hit:  X:-16.99

I tried disconnecting my Z endstop from the control board and it made no difference.

Is there a way to re-set the Endstops or something?  Any advice/direction would be greatly appreciated.

Thank you


  • You are not using repetier-firmware so check on your firmwares pages for how to change endstop settings. But yes, I think your endstops show triggered when not and that prevents move in triggered direction. That is quite normal and needs just a different firmware configuration inverting the signal or maybe also adding a pullup if it is a mechanical endstop.
Sign In or Register to comment.