Speeds changes after firmware modification

HI. I have repetier 0.92 since a while. No problems at all. Today O changed my Z threaded rods to lead screws. So I changed my Z steps in configuration.h. I uploaded the firmware useing the arduino software, I did a M500 command follewed by a M501 command. it went ok. No other changes in the file were made, just the Z steps. My past and actual Z related values are: Z max feed rate 1, homeing Z speed is 2, Z accel is 100, Z jerk is 0.3
The problem is that now the Z speed seems to be stuck at 2 whatever moement I try to do. Useing repetier host if I move the Z axis it moves really slow, I asume it is moveing at a speed of 2. Homeing also is slow, at a speed of 2. I have trid to change the max feed rate from the repetier host eprom tool, I tried with a value of max z feed rate of 4 and z homeing speed of 4. Then a M500 command and a M501 command (in that order) and still the speed of Z axis is stuck in 2.

What is hapenning here?


  • If you changed the Z steps in the config.h  and uploaded the firmware, you will still have the old Z steps in eeprom.

    this will read settings from config and save to eeprom
    or you can just edit the eeprom directly via repetier host, (no need to do the M501,M500) as eeprom is updated real time.

    Your new lead screws are most likely the 4 start variety so will have a Z step of 400
    On my prussa I3 clone i use Z_steps 400.  Z max feed rate 28.  Z accelleration 800. Z jerk 0.3
  • edited March 17
    Well, thanks to you I somehow solved it, but if it is posible please help me a little ore to understand:

    1- I already was doing the changes through repetier host. But it didnt worked. I tried a value of 5 for max z feed rate (that was the value most people said it should be the max, but I guess that value is for threaded rods and not for lead screws? because they definitly moves faster?
    2- with your info I changed the z aceleration to 300 (your 800 scared me jajaja I never saw that values before, but this is the first time I use a lead screw) And there was an instant change, speed was now being acepted (the value was 5). So then I changed also the max feed rate from 4 to 20 and now it moves fast as I want.
    I guess the problem was the acel and speeds in relation with the steps? The steps for this lead screws are 800. Is a 8 mm lead screw, dont know what a start is, but useing the calculator from prusa didnt help me since it seems this lead screw is not a standar size. So I found the steps doing maths.

    Only problem now: the speed still is super slow using the LCD controller....
Sign In or Register to comment.