compiling problem: Arduino IDE


I tried today to compile the repetier firmware with the Arduino IDE version 1.06. I used the firmware from the configurator (v0.91 and v0.92 but with same result). When I start compiling I get the folowing error message in the commands.cpp sketch:  

Arduino: 1.0.6 (Windows 7), Board: "Arduino Mega 2560 or Mega ADK"
Commands.cpp:24: error: 'E0_PINS' was not declared in this scope
Commands.cpp:24: error: expected `}' before numeric constant
Commands.cpp:24: error: expected ',' or ';' before numeric constant
Commands.cpp:24: error: expected declaration before '}' token

Can anybody give me an hint what is going wrong there, please?

Kind Regards,



  • It is the sensitiv epins line there, which comes from pins.h at the bottom.

    Question is why is E0_PINS not defined for you? What board (MOTHERBOARD) did you select in configuration,h that it has no E0_PINS entry?
  • edited January 2015

    I use a Ultimaker v1.5.7 Motherboard. I have configured it in the online configurator and made no further changes by hand. My entry in the configuration.h is #define MOTHERBOARD 37
    in the pins.h under the section for the Ultimaker 1.5.7 (Line 501 ongoing) I can not find an entry for E0_PINS. I copied the line 396 from RAMPS_V_1_3 section (#define E0_PINS ORIG_E0_STEP_PIN,ORIG_E0_DIR_PIN,ORIG_E0_ENABLE_PIN,) into the Ultimaker section (Line 559). Afterwards it was possible to compile the firmware without errors. But currently I do not understand why. Is there any reason why this line is missing in the Ultimaker section? Maybe I found a bug. Thank you very much for your support!

    The Firmware is running on the device (communiccation with the Repetier Host is possible) but the Display is not displaying anything. I´m using an RepRapDisscount Full Graphic Smart Controller. The wiring is ok, EXP1 is connected to EXP1 on the board, as well as for EXP2. Of course I configured it in the Online Configuration tool. Any Ideas what maybe went wrong there? Thank you!

    Kind Regards,


  • It is missing because I did a mistake writing that part I guess. Having no ultimaker it is hard to detect. Will fix that for next release.

    Regarding display it is not configured for Ultimaker board. So the pin numbers are not set correctly hence it will not display. Check in ui.h the section for the RRD display. There you see conditions for RAMPS and RUMBA board to set pins. Add there a similar section for ultimaker and find out the pin numbers, then display will also work. sd card will only work if spi/miso/5v/gnd are at the same pins as on RAMPS and RUMBA. Not sure it is compatible without tricks. Anyhow, if it is compatible and works please send me your fix and I put it on the official release to help others with the same combination.
  • edited January 2015
    Hello and Thank you for support.
    I had a look into the schematics of the Ultimaker1.5.7 board and into the schematics of the RRD Display. The Pining is commpletely diffrent. Also the powwer supply is on diffrent Pins. So if I want to get this running an adapter is neccesary. Currently I´m not intressted in building such an adapter. I started to setup my configuration with the end switches and stepper drives. But I have a lot of other problems as well. The drive attached to the Z axis amp is not intressted in doing any step. I changed the lolu board to an other one known as working but nothing. The wiring of this stepper is of course ok. I´ve tested it on the X axis connection of the board.
    Also when I press homerun button in the Repertier Host Software the X and Y axis is moving. But the X axis is running in the correct direction for the first couple of steps and then it is running in the wrong direction. The end stop is not triggered during this opperation. I tried to set the "invert direction" for this axis nothing changed.
    Independing of this changes I have another issue. I checked the box for Z-correction in the online configuration Tool. When I compile this I get an error of the compiler shown in the printer.cpp line 1663 (Printer::runZProbe(ix == 0 && iy == DISTORTION_CORRECTION_POINTS - 1, ix == DISTORTION_CORRECTION_POINTS - 1 && iy == 0, Z_PROBE_REPETITIONS))),):
    Arduino: 1.0.6 (Windows 7), Board: "Arduino Mega 2560 or Mega ADK"
    Printer.cpp: In member function 'void Distortion::measure()':
    Printer.cpp:1663: error: 'runZProbe' is not a member of 'Printer'

    The end of it is I´m a little bit frustrated. It looks like the Ultimaker1.5.7 board is not realy a common device like i thought and as good as others supported. I ordered now a RAMPS 1.4.Hopefully this will solve most of my problems.

    Thank you for your support!
Sign In or Register to comment.