Auto level - Prints about 10mm above bed.

I've been struggling to get auto-leveling to work.

I'm using a BLTouch sensor.

The sensor is working fine and I can do a G29, and a G32 S2 with no problems at all.

However, when I start printing, it tries to print a few centimetres above the bed.

This is my start code...

G21        ;metric values
G90        ;absolute positioning
M107       ;start with the fan off
G28 X0 Y0  ;move X/Y to min endstops
G28 Z0     ;move Z to min endstops
G32 S2 ; 
G28 X0 Y0  ;move X/Y to min endstops
T0 ; 
G1 Z15.0 F{travel_speed} ;move the platform down 15mm
G92 E0                  ;zero the extruded length
G1 F200 E3              ;extrude 3mm of feed stock
G92 E0                  ;zero the extruded length again
G1 F{travel_speed}
;Put printing message on LCD screen
M117 Printing...

Any idea what is going wrong?



  • Some more information.

    Homes X, then Y, then Z to ZMin switch.
    Does Bed probing correctly.
    G1 Z0
    Moves the nozzle about 32mm above the bed, LCD shows Z0.

    The same thing happens using G29 instead of G32.

    Z Probe height is set to 4.1mm in eeprom (measured).

  • I have exactly the same problem.

  • #define ENDSTOP_Z_BACK_ON_HOME 0

    make sure this is st to 0
  • it was set on 20 !
    Now i set at 0, but i still the same problem, the nozzle up for ~10mm above the bed :/

  • Is z min switch also the z probe switch? Also check if bed caoting is set 0. Are you using dev version?
  • Hi o/

    I use the version 0.92.9 and i have #define UI_BED_COATING 1
    What is this parameter ?
  • If you have z max leveling or inductive z probe you can adjust height after homing to accomidate to different thick coatings e.g. Kapton or blue tape. Current thinkness assumed is visible in eeprom as bed coating thinkness.
  • I found my problem, the Z Probe offset was set in steps not mm, I think I read that it uses the same rules as the multiple nozzle offsets (which are done in steps), and the Config file I have doesn't specify units.

    Fixing that, and then using the right entry to modify the Z Probe height sorted my problem out.


Sign In or Register to comment.