Resolution setting changes nothing.

edited February 2017 in Repetier-Firmware
Hi, I am a previous user of repetier firmware and have had success with it so I figured I would use it for my new corexy 3d printer. Most things are working perfectly, but there is a big problem: The motors only travel 1/2 of the distance I tell the machine to move. I have changed the resolution settings and tried adding a delay for gantry systems etc. None of the things I have tried change the outcome. I don't think it is an EPROM problem because every time I reupload the whole firmware package to the RUMBA board(It could be). I try 100steps per mm it moves 100mm, 200 steps per mm it still only moves 100mm, and even 400 steps per mm and the distance never changes. So basically the problem is that even after changing the resolution and some other settings, it always travels 100mm when it should travel 200mm or more. I am currently lost and could really use some help. 

I have another problem that likely goes with this if it is too far from the end stops then it will stop at some distance and act like it hit the end stops and just stop.I have also tried setting my printer size to much larger than the actual size and still nothing for this issue. 

BTW I have tried the stable and beta firmware versions.  
Many thanks.   


  • Why do you not think it is a eeprom problem since you reupload. That normally dow snot change resolution as it is stored in eeprom, so change it there and do not recompile at all. Alternatively copy config to eeprom after uploading with

    Not sure what you want to say with endstop problem. You say if you do not hit endstop it acts like hitting it so you have inverted endstop signals? Use M119 to see if they are signaling correct. Also make sure to move back from endstop when hit during homing. This is important for core xy printers.
  • Thank you... It worked 
Sign In or Register to comment.