Are my firmware settings wrong?

Hi forum,
When I try to use manual movement on repetier server my machine moves about 5mm whether I send a 1 or 10mm command. The manual movement does not seem to work on the 0.1, 50 or 100mm commands at all.
On another matter, while using the control knob on the machine itself, the Z stop registers 'on' on my LCD screen (RepRap Mendel mkIII) but stops movement only in the upward direction. Would reversing the Z axis on repetier server remedy this?


  • Check endstops with M119 . Sounds like your endstop trigger when not active preventing moves in endstop direction. Also check in eeprom if your steps per mm are set correctly. If not a 10mm move comes out 5mm.
  • Thanks for that.
  • Hi Forum,
    In the Eeprom it says my steps per mm are: -
    • x axis 100
    • y axis 100
    • z axis 4000
    is this correct?
    If it's any help, I inspected the stepper motors and they were marked 1.8 deg/step.

  • My z-axis when homed will only move toward the end stop with the movement in the free direction totally restricted. I have tried to inverse the axis in settings and, although it moves in the right direction, the end stop problem still occurs.
    I have tried to calibrate the end stops with an M119 command but the problem persists.
    Any help will be gratefully recieved. 
  • edited March 2017
    With no endstops pressed,  send M119 to the printer,   does it say the endstops are L  or  H

    If they are showing H when not pressed then you need to change the endstop switch types from normally open to normally closed or vise versa, in the firmware config tool under mechanics/endstops.

    What size pullies are fitted on X and Y motors, how many teeth ?
    If they have 16 teeth then 100 is correct for X,Y steps.
Sign In or Register to comment.