Autolevel bed error

Hi,

i've just tried out the 1.0.0dev Version.
Now when i try to probe Z and calculate Z Plane i get an error saying:

21:41:00.951 : fatal:Could not activate z-probe offset due to coordinate constraints - result is inprecise! Printer stopped and heaters disabled due to this error. Fix error and restart with M999.


What does this error mean?

This is my EEPROM Config:

epr pos type value
Language 1028 0 0
Baudrate 75 2 115200
Filament printed 129 3 35.238
Printer active 125 2 56473
Max. inactive time 79 2 720000
Stop stepper after inactivity 83 2 360000
X-axis steps per mm 3 3 160
Y-axis steps per mm 7 3 160
Z-axis steps per mm 11 3 800
X-axis max. feedrate 15 3 200
Y-axis max. feedrate 19 3 200
Z-axis max. feedrate 23 3 20
X-axis homing feedrate 27 3 40
Y-axis homing feedrate 31 3 40
Z-axis homing feedrate 35 3 10
Max. jerk 39 3 20
Max. Z-jerk 47 3 0.5
X min pos 133 3 0
Y min pos 137 3 0
Z min pos 141 3 0
X max length 145 3 203
Y max length 149 3 220
Z max length 153 3 234.303
X-axis acceleration 51 3 800
Y-axis acceleration 55 3 800
Z-axis acceleration 59 3 100
X-axis travel acceleration 63 3 800
Y-axis travel acceleration 67 3 800
Z-axis travel acceleration 71 3 100
Coating thickness 1024 3 0.15
Z-probe height 808 3 4
Max. z-probe - bed dist. 929 3 5
Z-probe speed 812 3 2
Z-probe x-y-speed 840 3 150
Z-probe offset x 800 3 55
Z-probe offset y 804 3 0
Z-probe X1 816 3 10
Z-probe Y1 820 3 10
Z-probe X2 824 3 170
Z-probe Y2 828 3 10
Z-probe X3 832 3 10
Z-probe Y3 836 3 170
Z-probe bending correction A 1036 3 0
Z-probe bending correction B 1040 3 0
Z-probe bending correction C 1044 3 0
Autolevel active (1/0) 880 0 1
Bed Preheat temp. 1048 1 55
Bed Heat Manager 106 0 1
Bed PID drive max 107 0 255
Bed PID drive min 124 0 80
Bed PID P-gain 108 3 196
Bed PID I-gain 112 3 33
Bed PID D-gain 116 3 290
Bed PID max value 120 0 255
Enable retraction conversion 1020 0 0
Retraction length 992 3 4
Retraction length extruder switch 996 3 13
Retraction speed 1000 3 40
Retraction z-lift 1004 3 0.3
Extra extrusion on undo retract 1008 3 0
Extra extrusion on undo switch retract 1012 3 0
Retraction undo speed 1016 3 20
Extr.1 steps per mm 200 3 192
Extr.1 max. feedrate 204 3 50
Extr.1 start feedrate 208 3 20
Extr.1 acceleration 212 3 5000
Extr.1 Preheat temp. 294 1 190
Extr.1 heat manager 216 0 1
Extr.1 PID drive max 217 0 230
Extr.1 PID drive min 245 0 40
Extr.1 PID P-gain/dead-time 218 3 25
Extr.1 PID I-gain 222 3 1
Extr.1 PID D-gain 226 3 120
Extr.1 PID max value 230 0 255
Extr.1 X-offset 231 2 0
Extr.1 Y-offset 235 2 0
Extr.1 Z-offset 290 2 0
Extr.1 temp. stabilize time 239 1 1
Extr.1 temp. for retraction when heating 250 1 160
Extr.1 distance to retract when heating 252 1 0
Extr.1 extruder cooler speed 254 0 255
Extr.2 steps per mm 300 3 192
Extr.2 max. feedrate 304 3 50
Extr.2 start feedrate 308 3 20
Extr.2 acceleration 312 3 5000
Extr.2 Preheat temp. 394 1 190
Extr.2 heat manager 316 0 1
Extr.2 PID drive max 317 0 230
Extr.2 PID drive min 345 0 40
Extr.2 PID P-gain/dead-time 318 3 25
Extr.2 PID I-gain 322 3 1
Extr.2 PID D-gain 326 3 120
Extr.2 PID max value 330 0 255
Extr.2 X-offset 331 2 1440
Extr.2 Y-offset 335 2 0
Extr.2 Z-offset 390 2 0
Extr.2 temp. stabilize time 339 1 1
Extr.2 temp. for retraction when heating 350 1 160
Extr.2 distance to retract when heating 352 1 0
Extr.2 extruder cooler speed 354 0 255


Comments

  • It is telling you that the probe can not phisically reach the coords you have set for probing

    You have a 55mm offset to the right of the nozzle  and a X10 probe position, this will try to move the nozzle to X-45 to probe the 1st position
  • I see. I've corrected that and now it works.
    Stange, that 0.92 didn't mind about these coordinates.

    Thank you!
  • Nos so strange. 0.92 just worked with wrong coordinates instead of complaing that it is doing something wrong.
  • Hello, I have the same error message but I think I have the correct configurations:

    Z-probe offset X = 0
    Z-probe offset Y = 30
    Z-probe X1 = 200
    Z-probe Y1 = 30
    Z-probe X2 = 200
    Z-probe Y2 = 200
    Z-probe X3 = 170
    Z-probe Y3 = 130

    I also note that the first point isn't the real Y=0 ( [Y1] - [Z-probe offset Y] ) but actually the Y=30 itself.
    I'm running 1.0.0dev from Feb 2nd 2017.



  • Y will always show real coordinates without offset. 

    Please check offset also in eeprom, not that it is there 0 from previous uploads.
  • I tried both considering and not considering offsets, both cases result in error.
    I got the these values from EEPROM itself.

    More info:
    Cartesian printer, software endstop for XYZ max, mechanical for XYZ min, 200mm limit for XYZ, z-probe is the z-min endstop, servo mounted.
  • OK, i thought it was not setting offset. Did not notice that a error happens.

    That error is easy to fix. Just got to y = 30 so you can activate probe. For homing set probe position for z to 0 / 40. This requires homing order XY Preheat Z.
  • edited March 2017
    Sorry I didn't understand. I'll try to explain better what is happening:

    The error starts when I send G32, with the configuration send above.
    Together the log error message there is a pop-up window;

    My default probe points are: 200;0 / 200;200 / 0;100
    - [Z-probe offset y] = 30 I get error running G32
    - [Z-probe offset y] = 0 no errors

    I tried to compensate like MartinH said:
    New probe points: 200;30 / 200;230 / 0;170 == results error
    Another try: 200;30 / 200;170 / 0;170 == results error too

    Any thoughts on this? 


  • Hello, I have the same error message but I think I have the correct configurations:

    Z-probe offset X = 0
    Z-probe offset Y = 30
    Z-probe X1 = 200
    Z-probe Y1 = 30
    Z-probe X2 = 200
    Z-probe Y2 = 200
    Z-probe X3 = 170
    Z-probe Y3 = 130

    I also note that the first point isn't the real Y=0 ( [Y1] - [Z-probe offset Y] ) but actually the Y=30 itself.
    I'm running 1.0.0dev from Feb 2nd 2017.



    Z-probe offset Y = 30
    this indicates that the probe is located 30mm behind the nozzle ?

    If so, then try

    Z-probe X1 =1 0
    Z-probe Y1 = 40
    Z-probe X2 = 200
    Z-probe Y2 = 40
    Z-probe X3 = 10
    Z-probe Y3 = 190
  • Hello Martin!

    Thanks for the idea, I got your point, it works (even with 31) and I may know why:
    The 30mm safety margin we sent on p1 and p2 is not enough maybe because I have some tanXY compensation.

    So what we learned is:
    1. P1,2 and 3 needs to compensate the Z-probe offsets;
    2. The safety margin needs to consider the any tanXY compensation you may have; 

    Am I right?
  • THANKS & QUESTION

    ===THANKS === 
    First of all thank you guys for version 1.0 dev! It works much clearer now. 
    The points for probing now should have the coordinates where probe (not nozzle) should come. 
    For example my probe is located 27 mm in X-direction from nozzle. So if I want to probe 
    P1 at x=28 and y=20 I enter in EEPROM "Z-probe X1 28", "Z-probe Y1 20". 
    (In version 0.92 in this case you had to input "Z-probe X1 1", "Z-probe Y1 20" and firmware would have added 27 mm of probe offset to bring the probe to the point x=28, y=20). 
    And thank you Martin for clear explanation!

    === QUESTION ===
    After completion of autobedleveling the X-carriage makes a movement in X-direction for about a distance of the X-offset my probe has. Do I understand right that it just places the nozzle to the point of last probing? 


  • Yes, it just puts the nozzle back to its correct position.
  • Boa tarde, estou com o mesmo problema, versao 1.0.3

    eeprom

    <epr pos="1028" type="0" value="3">Language</epr>
     <epr pos="75" type="2" value="250000">Baudrate</epr>
     <epr pos="129" type="3" value="218.626">Filament printed</epr>
     <epr pos="125" type="2" value="203022">Printer active</epr>
     <epr pos="79" type="2" value="0">Max. inactive time</epr>
     <epr pos="83" type="2" value="360000">Stop stepper after inactivity</epr>
     <epr pos="3" type="3" value="80.0000">X-axis steps per mm</epr>
     <epr pos="7" type="3" value="80.0000">Y-axis steps per mm</epr>
     <epr pos="11" type="3" value="2560.0000">Z-axis steps per mm</epr>
     <epr pos="15" type="3" value="200.000">X-axis max. feedrate</epr>
     <epr pos="19" type="3" value="200.000">Y-axis max. feedrate</epr>
     <epr pos="23" type="3" value="10.000">Z-axis max. feedrate</epr>
     <epr pos="27" type="3" value="40.000">X-axis homing feedrate</epr>
     <epr pos="31" type="3" value="40.000">Y-axis homing feedrate</epr>
     <epr pos="35" type="3" value="2.000">Z-axis homing feedrate</epr>
     <epr pos="39" type="3" value="20.000">Max. jerk</epr>
     <epr pos="47" type="3" value="0.300">Max. Z-jerk</epr>
     <epr pos="133" type="3" value="12.000">X min pos</epr>
     <epr pos="137" type="3" value="32.000">Y min pos</epr>
     <epr pos="141" type="3" value="0.000">Z min pos</epr>
     <epr pos="145" type="3" value="212.000">X max length</epr>
     <epr pos="149" type="3" value="232.000">Y max length</epr>
     <epr pos="153" type="3" value="200.000">Z max length</epr>
     <epr pos="1056" type="3" value="10.000">Park position X</epr>
     <epr pos="1060" type="3" value="10.000">Park position Y</epr>
     <epr pos="1064" type="3" value="10.000">Park position Z raise</epr>
     <epr pos="51" type="3" value="1000.000">X-axis acceleration</epr>
     <epr pos="55" type="3" value="1000.000">Y-axis acceleration</epr>
     <epr pos="59" type="3" value="100.000">Z-axis acceleration</epr>
     <epr pos="63" type="3" value="1000.000">X-axis travel acceleration</epr>
     <epr pos="67" type="3" value="1000.000">Y-axis travel acceleration</epr>
     <epr pos="71" type="3" value="100.000">Z-axis travel acceleration</epr>
     <epr pos="1024" type="3" value="0.000">Coating thickness</epr>
     <epr pos="808" type="3" value="10.500">Z-probe height</epr>
     <epr pos="929" type="3" value="5.000">Max. z-probe - bed dist.</epr>
     <epr pos="812" type="3" value="2.000">Z-probe speed</epr>
     <epr pos="840" type="3" value="150.000">Z-probe x-y-speed</epr>
     <epr pos="800" type="3" value="55.000">Z-probe offset x</epr>
     <epr pos="804" type="3" value="10.000">Z-probe offset y</epr>
     <epr pos="816" type="3" value="20.000">Z-probe X1</epr>
     <epr pos="820" type="3" value="20.000">Z-probe Y1</epr>
     <epr pos="824" type="3" value="160.000">Z-probe X2</epr>
     <epr pos="828" type="3" value="20.000">Z-probe Y2</epr>
     <epr pos="832" type="3" value="20.000">Z-probe X3</epr>
     <epr pos="836" type="3" value="160.000">Z-probe Y3</epr>
     <epr pos="1036" type="3" value="0.000">Z-probe bending correction A</epr>
     <epr pos="1040" type="3" value="0.000">Z-probe bending correction B</epr>
     <epr pos="1044" type="3" value="0.000">Z-probe bending correction C</epr>
     <epr pos="880" type="0" value="1">Autolevel active (1/0)</epr>
     <epr pos="1048" type="1" value="100">Bed Preheat temp.</epr>
     <epr pos="106" type="0" value="1">Bed Heat Manager</epr>
     <epr pos="107" type="0" value="255">Bed PID drive max</epr>
     <epr pos="124" type="0" value="80">Bed PID drive min</epr>
     <epr pos="108" type="3" value="196.000">Bed PID P-gain</epr>
     <epr pos="112" type="3" value="33.000">Bed PID I-gain</epr>
     <epr pos="116" type="3" value="290.000">Bed PID D-gain</epr>
     <epr pos="120" type="0" value="255">Bed PID max value</epr>
     <epr pos="1020" type="0" value="0">Enable retraction conversion</epr>
     <epr pos="992" type="3" value="3.000">Retraction length</epr>
     <epr pos="1000" type="3" value="40.000">Retraction speed</epr>
     <epr pos="1004" type="3" value="0.000">Retraction z-lift</epr>
     <epr pos="1008" type="3" value="0.000">Extra extrusion on undo retract</epr>
     <epr pos="1016" type="3" value="20.000">Retraction undo speed</epr>
     <epr pos="200" type="3" value="97.000">Extr.1 steps per mm</epr>
     <epr pos="204" type="3" value="50.000">Extr.1 max. feedrate</epr>
     <epr pos="208" type="3" value="20.000">Extr.1 start feedrate</epr>
     <epr pos="212" type="3" value="5000.000">Extr.1 acceleration</epr>
     <epr pos="294" type="1" value="190">Extr.1 Preheat temp.</epr>
     <epr pos="216" type="0" value="1">Extr.1 heat manager</epr>
     <epr pos="217" type="0" value="230">Extr.1 PID drive max</epr>
     <epr pos="245" type="0" value="40">Extr.1 PID drive min</epr>
     <epr pos="218" type="3" value="7.0000">Extr.1 PID P-gain/dead-time</epr>
     <epr pos="222" type="3" value="2.0000">Extr.1 PID I-gain</epr>
     <epr pos="226" type="3" value="40.0000">Extr.1 PID D-gain</epr>
     <epr pos="230" type="0" value="255">Extr.1 PID max value</epr>
     <epr pos="231" type="2" value="0">Extr.1 X-offset</epr>
     <epr pos="235" type="2" value="0">Extr.1 Y-offset</epr>
     <epr pos="290" type="2" value="0">Extr.1 Z-offset</epr>
     <epr pos="239" type="1" value="1">Extr.1 temp. stabilize time</epr>
     <epr pos="250" type="1" value="150">Extr.1 temp. for retraction when heating</epr>
     <epr pos="252" type="1" value="0">Extr.1 distance to retract when heating</epr>
     <epr pos="254" type="0" value="255">Extr.1 extruder cooler speed</epr>


    ainda estou aprendendo a utilizar o sistema
  • What command did you send and what is the error message? Normally it either that you start at a bad position like 0,0 where probe can not be activated or positions result in moves to illegal position due to z probe offsets.
  • edited April 23

    para g28 e g32, a seguinte mensagem


    fatal: Não foi possível ativar o deslocamento do z-probe devido a restrições de coordenadas - o resultado é impreciso! - A impressora parou e os aquecedores foram desativados devido a este erro. Corrija o erro e reinicie com o M999.


    It doesn't even start leveling or homing and the error already appears

  • I managed to correct the error, what was happening was exactly what he said, because my Z offset was positive but it should be negative

    After correcting this, the printer started working again.

    the only strange thing is that it happened overnight the error
Sign In or Register to comment.