Error m999/Heater and sensor decoupled |Davinci 1.0|

So i have this error for a while i saw on the internet that it could be the thermistor so bought some new thermistors replaced it powered on the printer tried loading some filament got same error checked the motherboard of the printer to see if the breaker went off (saw this on the ineternet as well) the breaker was fine after that i checked is anything was up with the wires they were fine tried unplugging and plugging the heating element. after all of that still got nothing so maybe i thought that the repetier code got corrupt during download so i downloaded a fresh copy wiped it and reloaded it on the printer and nothing.i need some help because i this point i don't know what to do help will be very much appreciated. -BlueRav3n

Comments

  • Posts: 0
    Maybe you just have configured timeout wrong or selected wrong sensor pin mixing bed and extruder. See if temperature gets up and also check error message on log for more informations. 
  • edited February 8 Posts: 14
    okay here is the error log of me trying to print something PS: not sure how to see if i mixed it up
    12:29:28.807 : FIRMWARE_NAME:Repetier_0.92.10 FIRMWARE_URL:https://github.com/luc-github/Repetier-Firmware-0.92/ PROTOCOL_VERSION:1.0 MACHINE_TYPE:DaVinci EXTRUDER_COUNT:1 REPETIER_PROTOCOL:3
    12:29:28.807 : Printed filament:152.41m Printing time:0 days 19 hours 21 min
    12:29:28.807 : PrinterMode:FFF
    12:29:28.822 : X:0.00 Y:0.00 Z:0.000 E:0.0000
    12:29:28.822 : DebugLevel:6
    12:29:28.822 : SelectExtruder:0
    12:29:28.822 : Begin file list
    12:29:28.858 : ad_check_0001 2400
    12:29:28.859 : Machine_Life.dat 14
    12:29:28.859 : SAMPLE01.gcode 2572641
    12:29:28.859 : SAMPLE02.gcode 426855
    12:29:28.860 : SAMPLE03.gcode 3829421
    12:29:28.910 : last_temperature.txt 2
    12:29:28.912 : offline_print.gcode 1068232
    12:29:28.913 : ad_check_0002 1400
    12:29:28.914 : eeprom.bin 4096
    12:29:28.923 : End file list
    12:29:28.925 : DebugLevel:6
    12:29:28.926 : SelectExtruder:0
    12:29:43.337 : Starting object analyser ...
    12:29:43.350 : Object is manifold.
    12:29:43.370 : Analysing finished.
    12:30:06.126 : CuraEngine command:C:\Program Files\Repetier-Host\plugins\CuraEngine\CuraEngine.exe -p -v -c "C:\Users\Miguelito Javier\AppData\Local\RepetierHost\cura.ini" -s posx=0 -s posy=0 -o "C:\Users\Miguelito Javier\AppData\Local\RepetierHost\composition.gcode" "C:\Users\Miguelito Javier\AppData\Local\RepetierHost\composition0.stl"
    12:30:06.378 : <CuraEngine> Cura_SteamEngine version 15.01
    12:30:06.378 : <CuraEngine> Copyright (C) 2014 David Braam
    12:30:06.378 : <CuraEngine> This program is free software: you can redistribute it and/or modify
    12:30:06.378 : <CuraEngine> it under the terms of the GNU Affero General Public License as published by
    12:30:06.378 : <CuraEngine> the Free Software Foundation, either version 3 of the License, or
    12:30:06.378 : <CuraEngine> (at your option) any later version.
    12:30:06.378 : <CuraEngine> This program is distributed in the hope that it will be useful,
    12:30:06.378 : <CuraEngine> but WITHOUT ANY WARRANTY; without even the implied warranty of
    12:30:06.378 : <CuraEngine> MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
    12:30:06.378 : <CuraEngine> GNU Affero General Public License for more details.
    12:30:06.378 : <CuraEngine> You should have received a copy of the GNU Affero General Public License
    12:30:06.378 : <CuraEngine> along with this program.  If not, see <http://www.gnu.org/licenses/>.
    12:30:06.378 : <CuraEngine> Default config 'default.cfg' not used
    12:30:06.378 : <CuraEngine> Loading C:\Users\Miguelito Javier\AppData\Local\RepetierHost\composition0.stl from disk...
    12:30:06.378 : <CuraEngine> Loaded from disk in 0.000s
    12:30:06.378 : <CuraEngine> Analyzing and optimizing model...
    12:30:06.378 : <CuraEngine>   Face counts: 9812 -> 9812 100.0%
    12:30:06.378 : <CuraEngine>   Vertex counts: 29436 -> 4906 16.7%
    12:30:06.378 : <CuraEngine>   Size: 24.875000 24.921000 9.415000
    12:30:06.378 : <CuraEngine>   vMin: 87.562000 87.539000 0.000000
    12:30:06.378 : <CuraEngine>   vMax: 112.437000 112.460000 9.415000
    12:30:06.378 : <CuraEngine>   vMin: 87.562000 87.539000 0.000000
    12:30:06.378 : <CuraEngine>   vMax: 112.437000 112.460000 9.415000
    12:30:06.378 : <CuraEngine>   Matrix: 1.000000 0.000000 0.000000
    12:30:06.378 : <CuraEngine>   Matrix: 0.000000 1.000000 0.000000
    12:30:06.378 : <CuraEngine>   Matrix: 0.000000 0.000000 1.000000
    12:30:06.378 : <CuraEngine> Optimize model 0.000s 
    12:30:06.378 : <CuraEngine> Slicing model...
    12:30:06.378 : <CuraEngine> Layer count: 31
    12:30:06.387 : <CuraEngine> Sliced model in 0.031s
    12:30:06.388 : <CuraEngine> Generating support map...
    12:30:06.388 : <CuraEngine> Generating layer parts...
    12:30:06.392 : <CuraEngine> Generated layer parts in -0.000s
    12:30:06.405 : <CuraEngine> Generated inset in 0.015s
    12:30:06.441 : <CuraEngine> Generated up/down skin in 0.032s
    12:30:06.579 : <CuraEngine> Wrote layers in  0.14s.
    12:30:06.579 : <CuraEngine> Wrote 383.4 kilobytes.
    12:30:06.579 : <CuraEngine> Total time elapsed  0.22s.
    12:30:06.579 : <CuraEngine> Print time: 494
    12:30:06.579 : <CuraEngine> Filament: 834
    12:30:06.579 : <CuraEngine> Filament2: 0
    12:30:55.900 : Printing layer 1 of 31
    12:30:55.939 : SelectExtruder:0
    12:31:24.909 : X:-33.00 Y:-12.00 Z:0.000 E:0.0000
    12:32:05.159 : DebugLevel:14
    12:32:05.194 : Error:One heater seems decoupled from thermistor - disabling all for safety!
    12:32:05.194 : Error:Temp. raised to slow. Rise = -0.42 after 31150 ms
    12:32:05.194 : Disabling all heaters due to detected sensor defect.
    12:32:05.194 : DebugLevel:14
    12:32:07.738 : fatal:Heater/sensor failure Printer stopped and heaters disabled due to this error. Fix error and restart with M999.


  • Posts: 0
    Ok, i see we are missing one information - which heater is decoupled. Otherwise
    Error:Temp. raised to slow. Rise = -0.42 after 31150 ms

    is quite clear. Firmware enabled heater for 31 seconds and the heater got 0.42°C colder. So the thermistor that you have configured does exist, but is not the one for that heater. Try only heating bed or extruder in manual control to see which one has that error or if both have it. If both have it you know you swapped the pins.
  • Posts: 14
    Okay Just tested it, so the heat bed heated  up just fine no errors but when i tried the extruder the reading on the heat kept changing to 28 29 after a bit of that i gave me the error m999.
  • Posts: 14
    that it gave*
  • Sounds like extruder sensor has heated bed pin entered,
  • edited February 10 Posts: 14
    so is this a psychical error or firmware error and how do i fix it?
  • Configure the extrude with the correct thermistor pin selected.
  • edited February 11 Posts: 14
    Forgive me if i am incorrect but this is done on arduino Configuration.h
    also if you could can you tell me which section i am supposed to modify
  • In tools section the part where you set your extruder 1 thermistor pin.
  • sorry i am a newbie to this software so i have a slight problem i found the tools section repetier-host but i don't see where you set the thermistor pin all i see is Belt calculator , Leadscrew caluculator , and Bed height map.
  • edited February 11 Posts: 14
    i am really sorry i am confused, Okay let me recap so the problem with my printer is the thermistor pin is incorrectly configured and i need to go to the tools section to select the thermistor to the extruder. The only thing i am confused is that are we talking about the arduino configuration.h Or Repetier-Host, Because if we are talking about the Repetier-Host i don't know were the tools section is located.
  • We are talking about the firmware so configuration.h needs to be fixed and new firmware uploaded using Arduino IDE.
  • Posts: 0
    @BlueRav3n I'm pretty sure Repetier is talking about the Tools section when using the on-line configuration tool. In my configuration.h after its been downloaded and extracted,
    #define EXT0_TEMPSENSOR_PIN TEMP_0_PIN is line 85 in that file (configuration.h viewed with the Arduino IDE open and looking directly at that file).
  • edited February 12 Posts: 14
    Okay changed it but there is a new problem as soon as i turn the printer on it says on the interface "Def /    0[] 30/"
    this is the code i used 
    #define EXT0_TEMPSENSOR_TYPE 1
    // Analog input pin for reading temperatures or pin enabling SS for MAX6675
    #define EXT0_TEMPSENSOR_PIN TEMP_0_PIN
    // Which pin enables the heater
    #define EXT0_HEATER_PIN HEATER_0_PIN

    SideNote: Could this thermistor be defective aswell?
  • Posts: 0
    Is the thermistor for the extruder hot end hooked to T0 terminals? It should show ambient temp until  heated
  • edited February 12 Posts: 14
    what do you mean by hooked to T0 terminals? the lcd screen just says def / 0[] 30/

  • Posts: 0
    What controller board do you have.
    Can you post your complete configuration.h file

  • edited February 13 Posts: 0
    BlueRav3n said:
    what do you mean by hooked to T0 terminals? the lcd screen just says def / 0[] 30/

    I don't have a DaVinci, I use a RAMPS setup on my printer. I looked on the web, looking at a model on a website, it looks like a different control board, I'm unfamiliar with that one.Sorry I can't help you.
  • You said you had
    #define EXT0_TEMPSENSOR_PIN TEMP_0_PIN
    and replaced by
    #define EXT0_TEMPSENSOR_PIN TEMP_0_PIN

    which is no difference, so what else did you change? That is T0 pin normally used. And before you got a temperature so this all makes no pin. So maybe you say whcih board you use, that sensors and where connected. But I don't know davinci boards so can not say if they use thermistors or thermocouples.
  • edited February 13 Posts: 14
    there is not much change i can give it because if i change it to 0 to 1 it will select the heat bed, the only thing i changed was the type of temp sensor.type of board i use for the davinci 1.0 is arduino due, type of board my davinci has is the new davinci boards (aka not sure what type of board)

    Link to my configuration.h: http://pastebin.com/9DquYwV7


    Side Note: davinci pins are weird because pin 0 = Extruder Thermistor and pin 1 = Heatbead thermistor

    #define HEATED_BED_SENSOR_PIN TEMP_1_PIN

    #define EXT0_TEMPSENSOR_PIN TEMP_0_PIN


  • Maybe you ask in the davinci github for help as you are using the modified firmware. They will have more experience with your printer and be of more help.
  • Okay Thanks
Sign In or Register to comment.