Z axis kossel moves double steps than x and y axis in kossel mini by he3d


I bought kossel mini from he3d and assembled but now I have faced
serious issue. I am struggling to get it working since last 15 days.

Steps I perform to start my printer.

My printer has J hot end with fan, no bed.
1) Connections done as it should be
2) Press home button : ====> all x,y and z move to top of the printers and stop properly at end switches.
I try to move nozzle down to calibrate it, nozzle is moving in front
direction ---> it should straight go in middle of the bed but it is
going to -Y direction always.

so uptill it reaches near to bed it will be to -Y direction totally instead of being at centre.

I believe Z axis motor is taking more steps so it is forcing nozzle to move more in -Y direction

  • With which Repetier product you have a problem?
     ==> Repetier 1.06
  • Which software version are you using? (We support only the latest version. If you use an older version, update your software and check if the error has been corrected ===> Repetier 1.06
  • Operating system type and version   ===> Win 7
  • Detailed error description  ===> Z axis in the kossel covers 200 mm while x and y takes only 100mm distance. They should be in sync to get the nozzle to centre.
  • Steps to reproduce the error  ===> Attaching configuration.h file ===> reproduced every time ===> http://youtu.be/NVSitSj5BYE
  • Attach required files including configuration files to reproduce the error.===> attaching configuration.h file  : http://pastebin.com/5UJcgauj
  • If the error occurs during printing, with which printer you work? ===> not able to start the printing due to issue. 


  • Highly appreciate help.

    Thanks Repetier team for creating such a good open source tool
  • Ok, sounds very wrong. Open eeprom settings and see if steps per mm is the same for all 3 also I'm quite sure only z value counts. When you move in pure z direction all towers must move the exact same distance. The distance also is exactly the z difference you said. So if you us eth ehost to move 100mm down and measure the difference you can exactly say which motor is moving wrong.

    Depending on the stepper driver you might need a higher high time to make the driver capture it 100%. So try increasing the following line to 1 or 2. 

    1. #define STEPPER_HIGH_DELAY 0

    If it does not help try switching your stepper drivers and check if it is still the same axis or the one getting the driver from the bad axis. In that case the driver might have current set wrong or it is simply defect (try extruder driver for testing). 

    If the difference is exactly 1:2 or 1:4 you have set microstepping for that driver different to the other 2. So set the jumper the same. I would suggest 1/16 for all.
  • You have the HE3D DLT-180 Kit?
    I'm running a such a printer from a .92 firmware with heatedbed + auto-leveling, and can send you the config file for it, if that would help.

  • issue was that one jumper on the z axis was missing due to which it was moving at double distance. 

    It would be great if you can send me config file to "madhavanihimanshu@yahoo.co.in"

    Thank you for your help. :)
  • hey d3bob or himanshumadhavani, could you send me a working config file to cole.cooper@okstate.edu? I just bought the He3d Delta 180 and am having some troubles getting it to work properly
  • Help extruder motor does not rotate, firmware helppp emmanuelgd1987@gmail.com
  • Try after M302 S1 so cold extrusion is allowed. There are some safety checks that could prevent extruder from moving. Running in dry run mode also prevents this.
  • I bought and collect DLT 180 HE3D.Firmware they sent is not installed.Please send the configuration file.
  • Hi d3bob. Could I get a copy of that config file? I also am having issues with an HE3D 180. 

  • Hi d3bob. 

    DLT 180 HE3D Firmware please. I'm also having issues with it.   This is my email , ebizsl007@gmail.com.

    Thanks !!!!!
  • WOW this sounds like a trend. can you just post your config.h :) I need it to.   terrance.tor@att.net

Sign In or Register to comment.