Head crash when moving past 1mm

G'day
This is driving me nuts! So far in fact that I put Marlin back onto my delta yesterday! 

I have relented, and put Repetier back, and want to resolve these issues.

1. I have set the height correctly (copied out of the working Marlin configuration.h) and have been trying to verify it in Repetier. What happens is that if I move the head down (g1 z10) and then jog it with the "Z" pad in Host is initially behaves correctly, but at about the 1mm point it suddenly crashed the head into the table. It's as if the movement has been multiplied by 10.

2. Auto level. This is weird, it starts off toward the z tower, checking in a line parallel to the x-z side. it then returns and starts again, moving still parallel to x-z towers. Does it again, but then attempts to leave the printable area, and triggers an error
14:01:25.547 : X:0.00 Y:0.00 Z:515.263 E:NAN
14:01:25.547 : Info:Autoleveling enabled
14:04:35.657 : Error:Cpos x square
14:04:35.665 : Warning:Invalid delta coordinate - move ignored x:-5002 y:-11568 z:39530
14:04:35.669 : Warning:in queueDeltaMove to calculateDeltaSubSegments returns error.
14:04:35.673 : Warning:executeGCode / queueDeltaMove returns error
14:04:35.722 : Error:Cpos x square
14:04:35.726 : Warning:Invalid delta coordinate - move ignored x:-4979 y:-11514 z:27858
14:04:35.734 : Warning:in queueDeltaMove to calculateDeltaSubSegments returns error.
14:04:35.738 : Warning:moveTo / queueDeltaMove returns error
14:04:40.780 : Printer reset detected - initalizing
14:04:40.780 : start
14:04:40.784 : Info:External Reset
14:04:40.789 : Info:Autoleveling enabled
14:04:40.797 : Transformation matrix: 0.999998 0.000393 -0.001900 0.000000 0.979301 0.202410 0.001941 -0.202409 0.979299

 The pattern seems to be a rhombus, but it errors out and the stored data attempts to put the bed centre right at the front of the bed.
The pattern looks like this:

       Z Tower
           .
         .   .
       .   .   .
     .   .   .   .
   .   .   .   .   .

What's going on?
Cheers
Poida

Comments

  • Posts: 20
    Oh, I should have said - The most important problem is the head crashing into the bed. Once that's sorted I'll look at what auto bed level is doing!
    Cheers
    Poida
  • Posts: 0
    First you should note that our implementations are often different then the Marlin way. In fact I do not know Marlin way.

    z height is most probably wrong if copied from marlin. We like to go down a bit after homing
    #define ENDSTOP_Z_BACK_ON_HOME 20
    This allows small moves at top without hitting endstops. As you know at top no xy move is posisble and that can cause errors if you hit endstops.

    I don't know why 1 mm should be 10 except if host had seen the click on the 10mm field. So here I assume more that host is sending 10mm. Enable commands in log to see what really gets send.

    Your autoleveling problem is quite simple as you have set the probing positions wrong. The 3 points build a parallelogram from P1->P2 and P1->P3, so P1 is the edge and in your case is not making it not a square but a parallelogram. That reults your probe coming inside invalid coordinates with the error you have shown.
  • Posts: 20
    G'day
    Thanks for the response. I do understand that Marlin and Repetier do things in subtly (and sometimes, hugely) different ways. I'm only hopping back to Marlin to try to understand the differences. My intention is to stay with Repetier. That being said, The checking I've done in Marlin was just to make sure I had my distance/length settings correct. Those were transferred into Reperier using the configuration pages.I have noticed that when I home using Host it does not move back off the stops. Where is the line mentioned above? Configuration.h? I'll go and find it when I'm back in the workshop!

    To do my checking (heights at towers, taking out the dome, etc) I used a block of known thickness as I had the head crash issue, so when I had my z height at 19.97mm and the block was snug I could go about getting it all done. It was used as a spacer so that I could pretend that it was my paper thickness for doing the calibration. (I hope this makes sense...)

    When I say 1mm becomes 10 I am not exactly sure - The head is too close to do any real checks, but once it throws itself onto the bed using the -z 0.1 to bring it up again it moved much more than 0.1mm It is a visibly big move. Where do I enable commands in log?

    Would Max Print Height in Machine setup on the Host have any effect? I have set it to 470 (stops is x0 y0 z514.29) so that I won't put a print job into Host that is too big on the edge of the print (to compensate for the dome at the top of the print area caused by the end stops)
    Cheers
    Pete
  • Posts: 20
    In relation to the auto level - My bed is 270 diameter. What would you recommend I put in for the P1, P2 & P3? Ideally I want it to do a grid, and thought I had set that up....
    Cheers
    Pete
  • Posts: 0
    Grid always as big as possible but it depends on the z probe offset what is possible at it moves to activate it. I thin a square of 150mm should be possible just offset it from center according probe offset.

    Host z height is assumend after homing, but firmware does not use that value and prevents moves below z=0 (in dev version I'm sure, in 0.92 I also think it does).

    To enable commands hit commands button in log toolbar. If you don't see log disable easy modem hit toggle log in top toolbar.
  • Posts: 20
    G'day
    Thanks for pointing out what I'd done wrong with the grid - I had P1 in front of tower A (-103.92; -69.28), P2 in front of tower C (0; 135) and P3 in front of tower B (103.92; -69.28) - hence the parallelogram that was protruding in front of the printer. That is now fixed. I should have paid closer attention to the documents....
    I sent G1 z1 to take the head down imm off the bed, then clicked on the Z jog -o.i
    Enabling Commands in the log shows that when I click z -0.1 it sends G1 z-0.1.....

    21:33:17.824 : N1360 M105*19
    21:33:20.486 : N1361 G28*38
    21:33:20.494 : Info:Autoleveling disabled
    21:33:20.889 : N1362 M105*17
    21:33:23.948 : N1363 M105*16
    21:33:27.011 : N1364 M105*23
    21:33:27.433 : SelectExtruder:0
    21:33:27.437 : X:0.00 Y:0.00 Z:516.950 E:NAN
    21:33:27.441 : Info:Autoleveling enabled
    21:33:30.077 : N1365 M105*22
    21:33:33.137 : N1366 M105*21
    21:33:36.200 : N1367 M105*20
    21:33:38.916 : N1368 G1 Z1*95
    21:33:39.259 : N1369 M105*26
    21:33:42.323 : N1370 M105*18
    21:33:45.388 : N1371 M105*19
    21:33:48.448 : N1372 M105*16
    21:33:50.831 : N1373 G91*39
    21:33:50.831 : N1374 G1 Z-0.1 F100*54
    21:33:50.831 : N1375 G90*32
    21:33:51.511 : N1376 M105*20
    21:33:54.576 : N1377 M105*21
     .... and it crashes into the bed on the click.

    Any ideas?
    Cheers
    Pete
  • Posts: 20
    I sent G1 z1 to take the head down imm off the bed, then clicked on the Z jog -o.i Should read: I sent G1 z1 to take the head down 1mm off the bed, then clicked on the Z jog -0.1 Sorry about that - I hate typing on an iPad!
  • Posts: 20
    G'day
    I've now set the max height to 50mm shorter that it actually is in order to properly look at what the distances are that are  being moved as the head approaches 0.
    Move the head to z1 (g1 z1)
    Jog 0.1 and the movement is 5mm This will happen from position z1.0 to z0.5. On the Host software and the printer screen it shows as a 0.1mm move, but the physical measurement is 5mm.
    From z0.5 to z0 the movements are once again the correct ones - clicking on z-jog -0.1 moves the head down 0.1mm.
    Positioning the head at z10 (g1 z10) and pressing the z-jog -10 it slowly moves down to 1.0 then quickly moved through the 1.0 to 0.5 distance (actually travelling 25mm) and completes the last 0.5. I varified this going up from 0 too: It does the same thing through the 0.5 to 1.0 travel.
    Are there any files or logs I can send to help figure this out?
    Cheers
    Pete
  • Posts: 20
    Now it gets interesting.
    I re-did the configuration using ver 0.91 R8 and now it works...????
    Very perculiar.
  • Posts: 20
    ....but now the extruder motor gets HOT and doesn't extrude.

  • Posts: 0
    What version did you use when it did not work? Just hunting also a bug with dual x axis where relative z move does not do, maybe the same problem.

    Have you set invert enable wrong for extruder motor? If it is on after enabling it is normally wrong.
  • Posts: 20
    G'day
    When it would just crash it was with 0.92. Re-doing the config with 0.91 caused the second issue.

    I'm not sure what you mean in your second suggestion. The plug is on correctly, because when I put Marlin back on it works fine. In ver 0.92 the extruder works fine, so it's not a connection error. I did not invert in the config as far as i can tell: What line is it in config.h. I've done a search on "invert" but haven't found anything that looks like it may be extruder related.
    Cheers
    Pete

  • Posts: 0
    Inverse is
    #define EXT0_INVERSE false

    Also make sure extrude ris hot or it will not turn unless you have cold extrusion enabled, whcih requires 0.92 or higher.

  • Posts: 20
    I have the following:
    #define EXT0_INVERSE 0
  • Posts: 20
    So I'm back to Marlin as it works.
Sign In or Register to comment.