Emergency stop

Please make the emergency stop button work when host controls the printer via the server.
I don't like to use the reset/stop button on the printer because of the random movements it can do after pressing the button. Pressing the emergency stop in host does nothing as of now.


  • For me it is working as expected.

    What firmware and board are you using?
  • edited January 2017
    Latest Marlin RCBugFix and the bord is GT2560 (using the Ultimaker pin definition).
    It works when connected by USB but not host -> server. The emergency stop also works from the web gui but sometimes it takes time to get to the option. Too long time. I have NEVER pressed the emergency stop by accident btw. ;)
  • Are you using latest server version. That is now also doing reset if possible. From host it is maybe still only M112 so it would be slow. Have to verify that when I update the server functions.
  • edited January 2017
    Yes, 0.80.3 and it still moves when using the reset button on the printer. Not all the time but too many to be ok. It starts moving slow diagonally towards back right when it happens. That's why I wan't easy access to software emergency stop.

    Edit: And yes, it might be slow. I tried pressing the button in host now when not printing and it worked! While printing or heating, it does nothing. Tried just now and it does not reset or anything.
  • Ok, that narrows the problem. Gcode needs to be parsed by firmware to take effect so even with out of order execution the running command must finish to react on M112. Since old server did not support emergency stop by interface host could only send M112. Newer server versions support that as interface command which in parallel resets so we now need to update the host to use that instead if possible.
  • Yes please!  ^:)^
Sign In or Register to comment.