Firmware will not change Steps/MM

I am using an Azteeg X3 Pro board. I have M8 Ballscrews and was setting my Steps/MM to 825. This was the same settings I used on my Azteeg X3 board but it had a stepper controller go out and I decided to go with the PRO version. No matter what value I put in for the Steps/MM in the firmware it ALWAYS moves 1.75MM at 1/8 Stepping. At 1/16 it moves .75mm instead of 1mm.

I disconnected my VIKI 2.0 display and used just software to move the axis, same result.

I checked X and Y and they are off by .25mm also. I am using M2 belt with 16 tooth spockets. I have it set at 100 steps/mm. Again, no matter what I change it to, it stay consistantly off unless I change the jumper on the board from 1/16 stepping to 1/8 then it moves 1.75 instead of .75.

Any help?


  • Did you change steps in eeprom? Once uploaded these are used until you copy configuration.h settings to eeprom again using e.g.

  • That was it thank you so much.

    I am using the web configuration tool. I know when I made my last firmware for the Azteeg X3 board about a year ago there was a spot to select the information about the heatbed but I am not finding that now when running thru the configuration tool. I was pretty sure it was on the same tab as the extruders.
  • It still is in the Tools tab: Enable heated bed support (HAVE_HEATED_BED) must be enabled to see it.
Sign In or Register to comment.