Z probe config ?

edited December 2016 in Extruder & Bed
Hi folks.
First, my seasonal greetings to everyone !
I'm getting confused on how to setup my parameters to get auto-level working.

My layout of Z min endstop (inductive sensor), nozzle, bed and Z probe (optical distance sensor) is as follows:
  • When Z homing is done at bottom of Z-axis, I have set corresponding Z value to 25.0mm. This allows nozzle to go below (Z min endstop is a inductive switch so no collision).
  • Nozzle hits bed at Z = 2.5mm.
  • I have placed an optical Z probe on the printer head. The bottom of this sensor is about 85mm above the tip of the nozzle.
  • Z probe has been adjusted and it triggers (sees bed plane) at Z = 33.0mm
My problem is how to configure Z probe in firmware (I'm using firmware 0.92.9 and host 1.62) ??????
I cannot find meaning in EEPROM values....
This is what I have now:
<epr pos="133" type="3" value="-160.000">X min pos</epr>
<epr pos="137" type="3" value="-195.000">Y min pos</epr>
<epr pos="141" type="3" value="25.000">Z min pos</epr>
<epr pos="145" type="3" value="360.000">X max length</epr>
<epr pos="149" type="3" value="390.000">Y max length</epr>
<epr pos="153" type="3" value="290.000">Z max length</epr>
<epr pos="51" type="3" value="1000.000">X-axis acceleration</epr>
<epr pos="55" type="3" value="1000.000">Y-axis acceleration</epr>
<epr pos="59" type="3" value="100.000">Z-axis acceleration</epr>
<epr pos="63" type="3" value="1000.000">X-axis travel acceleration</epr>
<epr pos="67" type="3" value="1000.000">Y-axis travel acceleration</epr>
<epr pos="71" type="3" value="100.000">Z-axis travel acceleration</epr>
<epr pos="1032" type="3" value="0.000">Acceleration factor at top</epr>
<epr pos="1024" type="3" value="0.000">Coating thickness</epr>
<epr pos="808" type="3" value="120">Z-probe height</epr>
<epr pos="929" type="3" value="87">Max. z-probe - bed dist.</epr>
<epr pos="812" type="3" value="2.000">Z-probe speed</epr>
<epr pos="840" type="3" value="150.000">Z-probe x-y-speed</epr>
<epr pos="800" type="3" value="0.000">Z-probe offset x</epr>
<epr pos="804" type="3" value="0.000">Z-probe offset y</epr>
<epr pos="816" type="3" value="0.000">Z-probe X1</epr>
<epr pos="820" type="3" value="0.000">Z-probe Y1</epr>
<epr pos="824" type="3" value="0.000">Z-probe X2</epr>
<epr pos="828" type="3" value="0.000">Z-probe Y2</epr>
<epr pos="832" type="3" value="0.000">Z-probe X3</epr>
<epr pos="836" type="3" value="0.000">Z-probe Y3</epr>
<epr pos="1036" type="3" value="0.000">Z-probe bending correction A</epr>
<epr pos="1040" type="3" value="0.000">Z-probe bending correction B</epr>
<epr pos="1044" type="3" value="0.000">Z-probe bending correction C</epr>
<epr pos="880" type="0" value="0">Autolevel active (1/0)</epr>

When I execute G30 command from Z = 50.0mm, Z axis moves slowly down, Z sensor triggers, Z axis returns to 50.0mm and I get this message in log :

Z-probe:NAN X:0.00 Y:0.00

I have tried to change "Z-probe height" and "Max. z-probe - bed dist." but I do not know what these exactly do ...

Please, can anyone explain to me what these values correspond to my layout and/or how get things work correctly ?
Thank you


  • Z-probe height= the distance from bed too nozzle when the probe triggers.

    Max. z-probe - bed dist= How far the Z will move up befor doing next test.
  • edited January 2017
    Thanks for you post.
    From what I have understood, that's right for Z-probe height and Max. z-probe -bed dist.
    My printer has a limit switch an the bottom. So, to avoid collision of nozzle when homing, I've placed the inductive switch so that when homing is done, nozzle is physically at a distance of 23mm from the bed. From the printer settings, when homing is executed, I've set the software height to 25mm. Hence, nozzle can theoretically start to print at software height of 2mm.

    In this configuration, my optical sensor is placed above the nozzle and laser triggers at a physical distance of 87mm from the bed. But software height is when Z=33mm (when I manually move nozzle down).

    My question is how to set values so that bed levelling works ?
    I've put  Z-probe height = 2 and Max. z-probe -bed dist = 120.
    But I can't get G30 working as it says:

    Z-probe:NAN X:0.00 Y:0.00

    Can anyone help please ?

  • The NAN is the measured distance. Sounds like some value in EEPROM is not set correctly causing wrong computation results.
    120mm distance is a lot for probing. Makes  it slow as it has to go a long z way every time. 10mm is normally more then enough.
Sign In or Register to comment.