I have a printer from tronxy and I have trouble uploading it to v 0.92 and ABL if it give upload firmware led flasglhes twice and lots continuously for 3-4 seconds printer gets resetted and again it shows me the same old version on display and when I enter M115 I get the same program name. Pls help me out with it 
Printer is tronxy 
And board used is melzi v5 (as shown on board) 
And pls guide me with firmware file download location and instructions for updating it to board in a proper way 
Thank you


  • Check the log in the Arduino IDE to see what is happening. If it fails it will say so. If it does not fail you were uploading the old version again. Your description sounds like it should be but only the log will know.
  • edited December 2016
    in Arduino ide it shows Successful but after a second it again shows uploading..... untill i close arduino ide
    and i cant find the baud rate of previous software so i tried 112500 and others too  , even then it doesn't work  for 9600 and 112500 baud rates it has a blink and constant lit for 3 seconds 
    i have attached the board that i am using

  • Are you using the special sanguino uploader? Melzi is not arduino compatible so it needs it's own definition and uploader. Google melzi firmware upload for more details.
  • I had the same issue with this board when I first tried to upload a new firmware.  I suspected the bootloader was either not there, or in some way corrupt so it would not accept a new program.  I had to use a "proper" programmer to reflash the boot loader.  I did not own a AVR programmer so I used a raspberry pi I had lying around and followed adafruits tutorial (  I generated the HEX file by using the "Export compiled library" from the sketch menu.  This will create 2 hex files in your sketch folder - use the hex file that has "with_boootloader" in the file name.  If you have not got the Sanguino board options in the IDE yet I followed these instructions
Sign In or Register to comment.