Z axis motor not working after re upload

I am building a 3d printer and after connecting all the wires. The three motions were working perfectly. However, the end stops were not working as all the motors were going in opposite directions. So I updated the repetier firmware. While the endstops started working, the z axis motor stopped working. It does the "singing" sound but its not moving. Any suggestions??
These are my endstop settings



  • Reduce acceleration and/or max. speed. The sound are lost steps so motor tried to move but signals come to fast to follow. Maybe you just changed the steps per mm to a wrong value so frequency is higher, who knows. But one of this should help and then you see if steps per mm are correct or not.
  • I have tried changing all the setting but it still doesn't work
    The steps per mm is 1829 (M12 leadscrew)
    Homing speed is 2 (I tried 1 but it didn't work)
    Feedrate is 2 (I tried 1 but it didn't work)
    homing acceleration is 100 (I tried lower settings)
    max acceleration is 100 (I tried lower settings)
  • I tried using different motors too but it still doesn't work no matter how low I make all the settings. All it does is vibrate
  • Ok the z axis is finally moving but it is moving excruciatingly slow. Any solutions?
  • What did you change to make it move?

    If you just reduced speed then you must reduce friction and/or increase power to stepper motor. All drivers can adjust current to motor. But be aware that more power makes them get hotter and at some temp. thermal protection migh step in causing you to loose steps as well. Many printers use a fan to cool the drivers to prevent this.
  • I changed the steps per mm to 1829 and set everything else to default values. While its moving, its not homing in but would stop without even touching it
  • It stops when z endstop is hit or 2xz length is moved (or it thinks it is). 1829 is correct for 16 microsteps and 200 steps per rotation stepper motors. Can you say if 10mm move is 10mm? YOu could have 400 step motors or 32-256 microstep motors. Also z length could be set to a low wrong value. Check eeprom for current setting.
  • It did eventually reached home after me repeatedly pressing home. However, it won't move in any direction. It just makes a "tick-tick" noise 
  • Does it reach z switch?
    M119 should get high when it reaches switch. If setup prevents that and nozzle hits bed it might just loose steps and never reach endstop. For some reason your z axis seems to have not much force.
  • It does reach z switch and does stops there. But now, it won't move in any direction. It just makes that vibration that it was making before. I switched it with a different motor and now its doing the same thing
  • The z axis does the auto home pretty well. But won't move manually. So I decided to do a dry run with a part and z axis was way off. But since, the manual controls are not working, I don't know how to calibrate it
  • There is one more reason for vibration and that is if motor has only one coil powered. Since a different motor does the same I would try putting it in x axis for testing and x in z. In config tool you can easily switch sockets for functions. Then you know if stepper driver or some contacts have a problem. Always hard to say remotely what vibration you have.

    Z will not move if M119 shows a endstop H in movement direction. It will also not if not homed and you set it to move only after homing. And it may think it reaches printer boundary also preventing moves.
  • No need to worry. It turns out that the steps per mm in EEPROM wasn't changed. Than I changed it via the repetier host and now its working. 
    Sorry for the trouble. 
Sign In or Register to comment.