Extruder and bed heaters turn off shortly after printing starts

Manually I have had the extruder and heater both on up to temperature 140 and 55 respectively. But when printing either from warm condition after starting print or starting from cold and waiting after printing begins the extruder and heater are turned off. The message that they were turned off because the temperature dropped happens about 13 seconds after the temperature dropped on the extruder. That tells me why it would have turned them off but obviously not what turned them off before the temperature started to drop. How do I go about troubleshooting what causes the temperature drop on the extruder that then causes the message that comes too late?


  • Here is some more info related to the issue:
    I get the Error message after the heater has been turned off
    19:53:43.785 : DebugLevel:14
    19:53:43.797 : Error:One heater seems decoupled from thermistor - disabling all for safety!
    19:53:43.798 : Error:Temp. raised to slow. Rise = -12.58 after 13079 ms
    19:53:43.802 : Disabling all heaters due to detected sensor defect.
    19:53:43.805 : DebugLevel:14

    If I manually set the temperature it is stable and stays there for a long time
    As soon as I start to print after coming up to temperature or having had the temperature stable and started to print, the heater gets turned off somehow and I get the message above about 13 seconds later according to the Temperature Curve and the time line and the log message

    I have attached an image for the case where it came up to temperature but the same thing happens if it were at temperature a long time (lets say 10 minutes or more).
    I also tried moving the extruder with the manual controls while it was at temperature and did not see this problem.

    I know the detection code is not causing the problem, only detecting it after the case.

    I would appreciate any suggestions.
  • You should enable extruder output in temp graph to see if firmware tries to heat at all.

    Things that might happen is that a fan gets enabled and cools the extruder more then it can heat.
    An other thing is if some other function (fan or something else) uses the same heater pin for it's function and overwrites the signals from heater.
  • I disabled cooling, I don't have a fan connected here is the output, similar to previous https://gyazo.com/40294d5eb3a95574254c1330e1b9e8e1
    I realized that it tops off before reaching the desired temperature but I don't know what causes that. Manually it goes up to 240 and wobbles there like it should being controlled around the target temperature.
    Here is an example under manual control.
    What else can I do to try debugging this? Is there some way to find all the pins being used, or to find the signal telling it that the sensor is not responding?
  • You still did not enable output graph for extruder in host temperature graph, so we still do not have the information if firmware wants to heat or not.

    But you captured in the log the error message - the red one - that explains exactly why it happens! It says after 13 seconds of heating it cooled down 6°C which is surely wrong.

    As manual heating works your code must contain a command that also controls the heater output even though it should not do that. There are not so many command before heating so finding the command that stops a enabled heater should be possible. Could still be one of the many fan controls e.g. board cooler that starts on same pin. At least weird error as manual works.

    Also a question is what happens if you preheat manually and then start printing.
  • Sorry I didn't understand at first what you meant about the extruder output. Here are all of the graphs.

    The output and the slicer gcode are here gcode  

    I thought that I mentioned previously that the same thing happens when preheating manually before printing.

    I took the temperature rising too slowly time and set it to very long and that is not printing out now as you can see, but the printing stops as the temperature is shut off.

    I will gladly do other tests, but I am not sure where to start. I am thinking about trying to just extrude small lengths of filament to see if that works. I am very confused about how all the internals count errors and  how they might be output. I am thinking about digging into the code and just printing out variable values to get some idea.

  • YOu clearly see firmware tries to heat full power and bed + extruder get colder. So it is not decoupling that is set wrong it is the reality that it is decoupled. You could try extruder allone without heated bed. Looks like the problem starts after a short while of powering both bed + extruder. Knowing bed can take quite some ampere it might be a fuse turning off? Many boards have a special output pin for bed that has a separate fuse for bed only. Could also be your power unit getting too hot and disabling itself. Other test therefore home and set temperatures only in host. Then when it happens try to move motors to see if you still have power. In any case bed/extruder get no power at some point also firmware opens the mosfets so find where the current stops coming and you have the source.
  • Excellent, that sounds like something I can look into. I appreciate your patience.
  • Thanks so much. I used two separate power supplies. One for the bed and one for the extruder. That did the trick. I have more tuning to do but it didn't stop anymore!
  • after I run a print I get    DebugLevel:14 from my heat bed and then both heaters shut off,How do I stop this ????
  • Fix the reason that causes firmware to go into dry run mode. In log sou see that a heater is defect or decoupled due to not getting hot fast enough. So assuming they work like normal you need to increase the decouple time for that device.
Sign In or Register to comment.