Prusa P802M, odd Z Homing

Hi there - I've got a ZoneStar P802M and am trying to upgrade to the latest Repetier firmware (0.92.9). This is in an effort to get auto-leveling enabled in firmware. I haven't installed the autolevel probe as yet so still want to trigger on the Z min stop.

Everything is OK aside from some very odd Z homing behavior. If I trigger the Z homing, this is what happens:
- Z starts to move down
- hits the Z end stop switch
- Z moves back up away from the end stop switch the prescribed amount
- Z reverses and moves towards the end switch
- [at this point the homing should be complete once the end switch is triggered......]
- Once the Z axis hits the end switch, the z motors increase speed and keep moving down towards the bed (bad, bad, bad)

I'm starting with the generic P802M Configuration.h and only tweaking for the auto-level. I've tried various combinations of the end stop switch (NO, NC etc. - and making sure that the switch is registering correctly).

Any clues as to what is making the Z axis head towards the bed after the end stop is triggered?




  • You can set an extra move after homing. Should be positive and normally 0 for z min homing. (ENDSTOP_(X|Y|Z)_BACK_ON_HOME).

    Also if you have z min = z probe some extra moves might be added like bed coating (check eeprom) and correction for z probe height. Positive z probe height would mean go further down when homing triggers probe.

    I'm not sure what you exactly did since you say not havin z probe but testing autolelevel.
  • I'm eventually going to an auto-level setup  - so want to compile that in..... but for now simply use the Z-min endstop as I am currently have.

    Z_BACK_ON_HOME is currently set to 0.

    You may have set me on the right path though. Z_PROBE_HEIGHT was set to 40mm..... which may explain why it was continuing to descend (and 4mm seems like a lot). I guess for now, setting Z_PROBE_HEIGHT = 0 may be the answer..... I'll try that.

    (and yes, looking at things, I now see that I can't really enable auto-level without setting the parameters as I want them)


Sign In or Register to comment.