printer head x, y, z coordinates not in location and not visible

I installed the latest version of repetier under ubuntu 16.10 but the numbers of the x,y,z axis are not positioned in the space intended for it. 
and also... only two of the three are at all visible at all, and from these two it is difficult so see which coordinate it represents.  

any one else had this problem? and ifso, how did it get solved? if it did. 

greatz Matthieu


  • Can you post a screenshot of the problem. Hard to say what is happening from description.

    Also is that a high dpi monitor? High dpi often brings unexpected results in positioning.
  • i'm very willing to post a screen shot, had to figure out how though. 

    image from 2016-11-13 01-15-54.png?dl=0

    and am still not sure if this will work, thats why i tried 2 ways. 

    it is the same. i use two monitors.. one (basic) from the laptop.. and one higher resolution but the positioning is exactly the same. it is difficult to see though. 

    greatz Matthieu

  • You need to upload images to internet e.g. pastebin or dropbox and release the link or public folder.

    2 Monitors with different dpi settings might be a problem. Who knows from which monitor the font size is taken to compute positions. Does is also happen with only one monitor?
  • edited November 2016
    i did just that. uploaded it to dropbox and posted the link here as in through the insert image icon and directly. both links failed apparently. any idea what could've gone wrong? i pasted the public link.. also pastebin is only for text (as none pro users). so can't use that for pictures. 

    anyway your comment for the two monitors was worth trying out but to no avail. now even with only my laptop (asus f551mav) display all is exactly the same. 

    kind greatz 


    ps: i saw that the link post did work for file in my other post here in repetier forum so i thought to give it another try with the prnt screen of the situation with just one monitor. 

  • Ok, could see the image. Looks like a mix of 2 dpi settings. Some parts set images for high dpi others not while text seems to be for high dpi. Will test it with next release on windows. If it appears there I can fix it.

    Is this the only part having wrong size selections or do other tabs/windows also look so bad?

  • edited November 2016
    this was the only that i noticed directly as it is functional, but since you asked i went through the entire program and looked specifically for layout problems. 

    this is in no way a complaint..!! just me trying to answer your question to the full. many of the comments are mere details. but it's better to know and discard then not to know. 
    in general: when there are coloms of field (filled in or to fill in) it happens rather frequent that field over run each other (1 and 2e mostly, also tekst) i'll point them out as i go through but they are all in different parts. 
    1) main field (left)
     a) cura tab: print tab/ speed ad quality: both slow and fast : between print and travel (speed field) & name and layer height (quality field) 
     b) cura tab: print tab/ Structures & extrusion: basically all field, bottom once over ride each other or run out of the field. 
     b) 3d view tab: the field, slightly over rides the icons on the left. 

    2) right field ( right)
     a) slicer/ add slicer manager: name field over runs add slicer button partly
     b) print preview: all buttons: text and icons don't fit in. 
     c) SD card field: field overrides the icons. 

    3) printer settings
     a) connection: Communication time out over runs its field
     b) advanced : filter path and parameter field is over run by run filter after every slice field and tekst. 
     c) extruder (1 and 2) name and diameter field over run 

    4) preferences
     * 3D visualisations / filaments / colors  
    a) travel moves (green field) runs out of the field
     * 3D visualisations / filaments / Visualisations
    a) layer height and filament diameter fields over run
    b) text under filament diameter field has enters after  each lines, but the lines are to long. meaning there are 6 lines instead of the necessairy 4 lines. 
     * push messages: 
    a) tekst lines under host name, Informer groups and URL: are not at all or barely visible. 

    Belt calculator and leadscrew calculator: the lowest field run out of the box. 

    5) something completely different: 
    the monitor gives this error message. nothing important but easily fixed by changing the png files. 

    libpng warning: iCCP: known incorrect sRGB profile
    libpng warning: iCCP: cHRM chunk does not match sRGB

    again: no complaint from me here. just doing my 5 cents worth. 

    print scr added shows point 5 and 2b: if you would like some more prt scrn of other parts let me know which specific part. 
    but 2b is besides the known issue the most interfering. 

    ps: shot this prnt scrn with two displays active, but the problems are also there with just one. is verified. 
    psps: this is all under ubuntu (not windows) 

    kind regards Matthieu
  • Thanks.

    You can ignore the sRGB color warning. I guess some png files used are not using sRGB but some other profile.

    Will see if I can set dpi in ubuntu to test the error. All displays have normal dpi but in windows I can set it higher anyway so I think it should work in ubuntu also especially if it does not depend on 2 monitor setup as you said.
  • oke, 
    just let me know if you need any further info... 

    an other question.. 
    any idea how i can get some help on this topic? i really have no idea what the issue could be.. 
    is also no idea where to start trying to solve it. 

    grtz Matthieu
  • I don't think you can solve it except using only normal dpi displays or find a way to start at least host in normal dpi mode. In windows I know there are such compatibility settings that use normal dpi and scale up instead. This looks a bit unsharp but has at least correct display. Not sure if this is possible on linux. I'm more a linux command line user as I use linux personally only for our servers. That is something I will test when writing next host release.
  • what do you exactly mean with normal dpi? when is it normal? 

    and i understand i can't solve this issue.. but i was referring to the link of my other topic that is more emeregent to me and has no reply at all. was hoping you could have a look at it and maybe have some general idea where i should to start to solve that (the other issue) 

    kind regards 

  • I think normal is 72dpi also displays until 96dpi or so show pixels 1:1. If you have retina displays that would be high dpi. 8px fonts get unreadable and fonts need to be scaled. When this happens winforms gets complicated under windows and as it seems also on linux. On windows there is a option to internally compute with low dpi and scale image to your dpi to be readable. Looks a bit unsharp but works. That is what you would need to achieve under linux as well.
  • i wasn't at all sure about the dpi of my monitors. just the settings in pixels. 

    small monitor: 1366*768 pixels, 13.6"x 7,7" size = 100 dpi 
    larger monitor: 1920*1200 pixels, 20.5" x 12,8" size = 94 dpi 

    so both are rather on the edge, but nothing near retinal quality. 
    i see it as higher standard resolution. 

    hope this helps you. 

    kind regards, matthieu
Sign In or Register to comment.