Z Axis Motor Moving very slowly

Hi I am upgrading a CubePro Duo to Ramps 1.4, and i have used the new version of the complier to create the Firmware, but the Z axis is moving way to slowly, i have tried to change the steps per mm but this has no effect, is it because i have the micro stepping jumpers installed, i have an older version of firmware from a german riprap x400 when i install that and move the z axis it moves at a better speed, and in this firmware it has a line of code to define the micro stepping setting, but in the new firmware compiler it does not have this setting.

Can someone give me a hint as to how i fix this.


  • You always needed to set steps correctly. Check in eeprom settings what your setting is and modify there. Only changing in configuration.h will not work.
  • edited November 2016
    Ignore this dum question, if i had of just opened the software and looked i would have got the answer, which his yes the settings can be changed.
    Can i change the eprom setting using the Arduino programming software.
  • edited November 2016
    Or do i tell it to ignore eprom settings on startup?
    Because the X400 firmware eprom settings match the new version i created?
  • You can copy defaults to eeprom with

    or disable eeprom at all if you compile with EEPROM_MODE 0, but that is normally a bad idea since you then need to upload for every tiny adjustment.
Sign In or Register to comment.