Can't get print to start with Cura slicer

I'm completely new to this world of having my own printer to bare with me if there is a really easy answer to this....
Oh, here's some pertinant information
  • Repetier Host 1.0.6
  • Window's 7 machine
  • Bukito printer
So for the most part everything seems to be working. I can control the motors and the temp head manually, the
print head comes up to temp,  and I can see that Cura has sliced
everything.  When I start a print though it goes to
home and then takes itself to (0,0,15) and just stays there...  I don't understand gcode, but it seems as though it's
making it to the final wait for extruder to come up to temp and then it
just stays there...


Here's the bottom of my log file- once it makes it here it just hangs out and keeps oozing out filament every minute or so:

12:35:36.695 : N71 G28 *5

12:35:36.695 : N72 G1 Z15 F100 *20

12:35:36.697 : N73 M107 *49

12:35:36.697 : N74 G90 *3

12:35:36.697 : N75 M82 *11

12:35:36.698 : N76 M190 S50 *76

12:35:36.698 : N77 M104 T0 S210 *50

12:35:46.215 : ok

12:35:46.215 : ok

12:35:46.215 : ok

12:35:46.215 : N78 M117 ETE 9m 29s *99

12:35:46.215 : ok

12:35:46.215 : N79 M105 *57

12:35:46.215 : ok

12:35:46.215 : N80 G92 E0 *95

12:35:46.216 : N81 M109 T0 S210 *54



Right now I have the default temp set to 210, as well as the
setpoint in Cura. When I look at the extruder temp in the manual screen
the set is at 210, and the actual bounces between 209.7 and 210.2.  I feel as though there's something I'm missing about this temperature setting thing...  is there another place that temperature is also being set that I'm not seeing, or is this a completely different problem?

Here's my start g code
; Default start code
G28 ; Home extruder
M107 ; Turn off fan
G90 ; Absolute positioning
M82 ; Extruder in absolute mode
; Activate all used extruder
{IF_EXT0}M104 T0 S{TEMP0}
G92 E0 ; Reset extruder position
; Wait for all used extruders to reach temperature
{IF_EXT0}M109 T0 S{TEMP0}

I tried removing the last line to see if that would make a difference but I got the same result
; Wait for all used extruders to reach temperature
{IF_EXT0}M109 T0 S{TEMP0}


So I gave up on Cura as the slicer for the moment and tried using Slic3r and now it's working just fine... 

This is definitely a step in the right direction, do you know why might cause the Cura slicer to get hung up like that?

Thank you so much for your help!


  • Since you see 210°C for extruder I guess you hang here

    M109 T0 S210

    which sets temperature to 210 and waits until temp. is reached. You can normally config firmware to only finish after some condition like 10 seconds within 1 degree or so. So my guess is your firmware is configured with a criterion that never finishes. As a test send

    M109 T0 S210
    M104 S0

    Over manual control (needs easy mode disabled)
    That should heat up till 210 and then go back down to 0.
    It is stays at 210 it is what I said.
  • If I send those commands without anything already running they work just fine.  But if I send them after I've started a print that was sliced w/ Cura then it still stays in the same location.

    And as I said before, when I slice with slic3r everything works fine.  This means there must be something wrong with the g code that cura is making at the start of the print right?
  • Then you have to find the command in question. First enable ping pong mode to make it a bit easier (only for debugging since it is faster if disabled). Then watch your log where it stops and try identifying the line. It might be a few line upwards from what you see in log. Once you know which line it is, you can check where it comes from, e.g start code or already created from cureengine but maybe for wrong flavour.
  • Thanks your your response!  I'm out of the office for the holidays, but I'll try debugging this and let you know what I find as soon as I get back next year.

    Happy Holidays!

Sign In or Register to comment.