Heater working sporadically. Is it a G-code problem?

Hi there.

I'm using a Printrbot Simple Metal that was bought some time back for our MakerSpace shared workshop. I've used Repetier-Host on the shared Mac Laptop with no problem for a month.  They allowed me to take it home and I'm having problems.

I'm using Repetier-Host 1.0.6  with updated firmware (I'm 99% sure).

When I reset the Z-axis using the instructions on this site, everything was working great. I downloaded the virgin G-code for the fan shroud and printed it out with no problems.  The problem begins when I try to print my own models.

When I first tried to print my own models that worked fine before the computer and location change, they weren't printing well, but at least they printed. By not printing well, I mean there seemed to be gaps in between layers that there weren't with the shroud. Doing some digging, I went into Slicer, changed the layer height to .15 mm, changed the vertical shells to 5 from 2, and horizontal shells to 5/5.

For some reason, the exturder will not by any means heat up when I try to print my own models, but will print out when I use the G-code.


I went back to the factory Slicer settings, but that didn't help.

Any thoughts?  I have to return the printer tomorrow :(  Thanks in advance.


  • In case you use CuraEngine check the gcode start/end script if it sets temperatures. It must b ein the start code and hitting the generate default will create that script for you as a starting point. I guess you missed that step.
Sign In or Register to comment.