Repetier host & Smoothieboard

Has anyone had problems with the printer becoming disconnected from repetier in a few seconds of a print?
I'm  using Smoothieboard /Smoothieware and switching from Pronterface to Repetier host and having the problem: the prints stops after a few seconds and Repetier Not Responding (have to restart the computer). Any idea why that could be? I have no such issue with Pronterface/simplify3d
thank you 


  • What does the log say? Any errors like resends? In that case try hitting "ok" in manual tab at the bottom (easy mode off) and check if it continues. Might be a wrong resend handling then.
  • it says: communication time out - reset send buffer block. Tried hitting "ok" -does not help
  • I see a temperature so it seems to work at the beginning. Any more messages in log as the line we see in image?
  • Ok, you have working communication and at one point it just stops returning "ok". Do you have a display connected so you say if smoothieboard is still running?

    You could activate "ping pong mode" in "Printer Settings". It is a bit slower but exactly what Pronterface uses. So there is always only one command in the queue. It shows no resend so smoothieware was always happy until it stopped returning anything. Maybe if you enable logging in general settings you might see more, but I don't think so.
  • YES! I activated Ping-Pong mode and now it works!
    thank you
  • edited September 2016

Sign In or Register to comment.